Download

Having an issue with a third person spring boom camera clipping slightly through walls

Hi all,

I am having an issue with a third person camera on a spring boom clipping slightly through walls when turned on an angle close to the wall. It clips through slightly all objects with a collision. The camera boom has collision testing enabled with a probe size of 12.

Now I do have the camera to the right of the player as I didnt want the crosshair to be placed on the player.

Camera glitch:

Camera setup: (one on the furthest back right is the main camera)

Help or suggestions are much appreciated.

Thanks

After some testing i found that if the camera boom or camera itself is not around the same axis as the middle of the collision capture it causes clipping. If it is positioned within the middle of the capsule x axis it will not cause clipping.

I dont want my camera in the middle of the screen, that’s not the style of game I want, and it interrupts the crosshair placement.

Bump :slight_smile: any help is much appreciated.

I will suguest change near clip plane… I think there is a ini in your project or you can search for it in a global option inside the project settings… https://forums.unrealengine.com/showthread.php?93306-near-and-far-clip-planes

or simply add a bounding box of some short that help the camera not get near this walls.

https://answers.unrealengine.com/questions/305315/change-near-clip-plane-in-game.html

Umm, it seems to me you figured out the problem. Your camera is offset from the end of the spring arm, and the spring arm’s collision size is not big enough to cover it. So either rotate your spring arm to reach the active camera, or enlarge the probe size to encompass it. Personally I would offset the rotation of the spring arm, since having that big of a probe size would probably cause issues.

rather than rotating the spring arm, you could offset where this spring arm is attached to the capsule, instead of offseting the camera from its spring arm, as the colision sphere casted to prevent clipping is casted at the end of the spring arm, regardless of your camera’s position.

Have tried to modify this, but it causes other issues such as walking through a door, the camera spazzes out.

I cannot rotate the spring arm

I have tried this, but it still does it.

Bump! Anyone have a solution i can try to fix this?

What about use something like first person cam if behind hte character there is a wall? specially on the range where it guess messy? or havent tryied to add another spring arm like above the character and move/activate the camera there

I know this is much later, but for anyone currently searching for an answer, here is how I solved this problem for myself. I too wanted my crosshairs off to the side a bit from the character. When I had the attach point of my camera’s spring arm off to the side, where the crosshairs were, I had this same clipping issue. Once I moved the spring arm attachment back to within the character’s capsule, and instead moved the camera to the side via values set for the spring arm’s “Socket Offset”, I was good to go. For example, if the relative location of the spring arm was (0, 40, 50), you can get the same effect by changing it to (0, 0, 50), and then setting the Socket Offset to (0, 40, 0). The two values together will move the camera to the same location, but the clipping will go away because the spring arm is within the capsule.

Thanks dude, that helped. :smiley:

For anyone else wondering how to fix it, here’s an alternate explanation:

  1. Select your camera boom
  2. Under the Camera Tab look for ‘Socket Offset’
  3. Set the offset to the location your camera would have been in.

Thank you JMcComb & IlllIl for this suggestion! It works perfectly! :smiley: Been looking for this for a while!

Hi guy’s,

After spending all night Googling about clipping issues i stumble on this thread(sorry to necro i didn’t want to make another thread on same issue), my clipping problem start right after i followed a tutorial on making a true first person controller(body awareness), since i moved the camera to the head socket and position it to get the best player view and everything look sweet until i run or jump forward to a wall or object where the clipping nightmare began. In the tutorial the guy said to delete the boom so i don’t know what to think anymore about that true first person controller and if it would work correctly for network game.

Here a link to the tutorial in case someone more experience can pin point any errors in the setup leading to the clipping issues, the tut is only 2 min : https://www.youtube.com/watch?v=qLoQYzxMNZM&t=2s

Thank for any help since this issue id driving me nut!

Years later, still a useful solution.