Download

Having a lot of problems with importing animation from blender

So basically I’ve animated a walkcycle in blender for my makehuman model using the default MH rig but no matter what I do I can’t seem to get it into my project :frowning: I’m sure I’m doing something wrong and I haven’t been able to figure it out for the last couple of days so I’m asking for some help :slight_smile:

These are the export settings i’m using from blender:

I’ve also tried many variations of it and nothing seems to be working.

These are the import settings in ue4:

And these are the error messages I’m getting after I click import

Note: Jinn is the name of another model I had that used the same rig, I’ve deleted it through ue4 and even gone into it in windows explorer and deleted the bits that were left. This error doesn’t seem to always appear.

I’ll also attach the .fbx and .blend to the post, if someone gets it to work then everyone can use the animation :smiley:
.blend: http://www.mediafire.com/download/dvl0o5193ywhec9/humanwalk.blend
.fbx: https://www.mediafire.com/?86je27hqed3unnq

Hope someone can help! Thanks!

Hey leonn3k -

Can you upload the original Blender file? The links above only give me an FBX.

Thanks
Eric Ketchum

Woops! I must have accidentally copy/pasted it wrong, all fixed now.

But the problem is still here? :wink: Because in my case I was able to import the skeletal mesh + anims and just the anims

Guys,
For what it’s worth on the next release of Blender 2.71 I noticed that they are planning a major update to the .FBX exporting features. If I understood it correctly, I think they are updating to FBX 7.4 standard. This might solve some of our importing issues. See this link for more info

http://wiki.blender.org/index.php/Dev:Doc/Projects

Yeah, I’m still having the problem :stuck_out_tongue: I even tried it on a separate project and the same thing happened D:

Here you can see my importing/exporting settings:

Export:
43bb254f9e09a71e06c2d3c8be1f867e5438b929.png
**
Import (in this case just the skeletal mesh + anims, because when I just import anims, I leave everything at default):**
49ac6e2e1130a8b7c4e4f66310f7fb32de83e544.png

When it is still not working, I could also send you the fbx file, so that we can see if this just happens with your UE4 ^^

ok at afaik don’t use the 7.4 binary use the old 6.1 ascii

you’ll get the error on import but it should still work

Well I’ve reinstalled blender and it all seems to be working now :eek: The animation looks really awkward though :stuck_out_tongue: Looks like my animation skills still have quite a way to go hahaha I’ll fix it up tomorrow and upload it here incase anyone wants a makehuman walk cycle :slight_smile: Sorry for bothering you guys!