Has anyone encountered this before?, and what might the answer be to getting rid of this?

This is the error upon load up. Any suggestions?

/Game/ExternalActors/Project_X/0/SC/SWZKJXRB593QM1H6ZCYDBX : Failed import for StaticMeshActor /Game/Project_X.Project_X:PersistentLevel.StaticMeshActor_UAID_309C23E49FF61C1401_1124253293 Referenced by export GroupActor /Game/Project_X.Project_X:PersistentLevel.GroupActor_UAID_309C23E49FF6221401_1367981563

1 Like

Bumping this. Having the same issue.

I found the Problem in my case. I had an actor that spawned other actors and kept a reference to them in the PostEditChangeChainProperty(FPropertyChangedChainEvent& PropertyChangedEvent) method. It checked if it had previously created instances of the actors and if so, deleted the old ones before spawning the new ones.
Since that method apparently gets called during level load in the editor, it created new actors during level load but somehow still kept a reference to the old (destroyed) actors.
adding this guard fixed the issue for me:

if (GIsEditor && !GIsEditorLoadingPackage && !GIsCookerLoadingPackage && !GIsInitialLoad)

hope that helps

1 Like

I think you have merge mesh who was grouped and this happend, the engine is in search for the mesh in grouped mode, to clean it, just go to your project path to content and follow the error indication path to delete the nomed files.

In my case, going to content browser, right-clicking my root folder (Content) and using the “Fix Up Redirectors” option solved import issues. Just leaving it here for anyone finding this thread.

I think I moved a project file in Windows File Explorer instead of inside UE, which might’ve caused broken imports in my case. So it’s not a fix-all, but worth a try.


Go to “Build” window and click build “world partition minimap” this will maybe resolve your problem.

This worked for me, thank you so much!