Has Anybody had any luck building for 4.25.1?

Ive been at it for at least 5 hours and its driving me crazy. their documentation is useless, The SetupAndroid batch file doesnt work anymore, The Engine still doesnt output errors and just opens a webpage to the documentation website, their documentation says you can find the latest version of the sdk and ndk in the UEBuildAndroid.cs script, which also doesnt seem to be true. What version of the sdk and ndk do you need now?

Generally you would need to follow this guide for setup:

So NDK version 21, my SDK is versions 28 and 29, but generally Android Studio should download both for you automatically if you follow the instructions I linked.

I managed to deploy to mobile, but it seems there are some issues. Like blueprints with structures that contain arrays cause immediate crash of the game on actual device, but work fine or PC and mobile preview. Also no issue if deployed from 4.24.3, it’s just 4.25 and 4.25.1 that crash. I reported this last friday using bug submission form.
I tried debugging with Android studio but the game kept complaining about lack of OBB so I ultimately switched to working on something else for now. Might be a good idea to use 4.24 untill mobile gets sorted out.

I waste one week. I very frustrating. Try to convert my 4.24 android project to 4.25. I done everething from guide: https://docs.unrealengine.com/en-US/…dio/index.html
Unreal works. Device detected but when I launch project on my android device it crashes. I tried to migrate assets from previous to new project. It does not help. Please help…

So I followed that to the letter, I even made a tutorial on it for 4.25 Unreal Engine 4.25 Android Packaging Tutorial - YouTube
But once the 4.25.1 update came out, everything stopped working. Ive had about a dozen people contact me asking for help and idk what to tell them… the engine doesnt seem to be able to detect the sdk properly, and rather than display an error message in the output log, it just opens the documentation website… I have no way of even knowing what the problem is,
what i can say is after that update, the batch file in the extras folder no longer works, and ive tried manually intalling all the addons from android studio, that still doesnt seem to help.

This is how I’m running 4.25.1:

Apparently I didn’t get the NVPACK, same thing, batch file didnt work. But with this settup I can successfully deploy my level to an actual device, and it works untill you try some specific blueprints as I mentioned before. I just manually added paths to my SDK and NDK.


Alright Figured it out, if you run into problems you can watch the updated tutorial here https://youtu.be/4SY2Za6j7UY

I have been getting errors since I moved to version 4.25. I am solving a problem, another problem arises. It would be great if update or new version comes as soon as possible.