Hands for VR: SciFi

“Hands for VR: SciFi” brings three science fiction hand models to Virtual Reality developers.

6 Meshes cover all your SciFi needs:
• Futuristic Gloves
• Alien Hands
• Mechanized Gloves

PBR Materials, easily adapted to any scenario.
Simple Materials included, for Mobile VR usage.

You can find a screenshot with all skeletons here: Skeletons.jpg - Google Drive

Usage with the VR Template:
You have to change a little bit, but it is very easy. This time we did not include a Blendspace 1D.
First, you have to create a Blendspace1D for the skeletal mesh you want. For the blendspace, create two hand poses and save each as single frame animation. Put these animations into the blendspace 0 and blendspace 1 positions (don’t forget to change the Range from 0…100 to 0…1 in the blendspace).
Second, follow this tutorial that I made for the Basic Hands assets: https://www.youtube.com/watch?v=tQZygcnUz3A

Support email: marketplace@cykyria.de
Website: cykyria.de

We have updated the asset and it is now prepared to be easily used with the official VR Template.
Follow this guide to use it in the VR Template: Hands for VR SciFi - UE4 VR Template Integration.pdf - Google Drive
It’s just a few clicks and won’t take you longer than a minute or two.


Alright here is a pic of the Skeletal Mesh… that pinky is really too small and look at bottom left you will see EPIC’s axis and you can see the glove is different. the best way for a hand is to have it so thumb is on the top, and finger pointing in the direction of the x axis. Then all that would be required is a very little tweeking in UE4… I really like this Glove set by the way.

[USER=“637284”]Shao Lung[/USER] thank you for writing here.
About the pinky: it never occured to me or my artist like that. But now that you said it, you are right, it looks kind of small. I’ll see if we can add a version with a bigger pinky to the pack in the near future.

About the axis, I have freshly downloaded the asset into 4.26, the axis are right? Or is this not the glove’s skeleton you are showing? See my attached screenshot please.

Did you discover the PDF that is in the root folder of the project (it’s the same as here: https://drive.google.com/open?id=0B4…RX1VTa0xpWFE )? In chapter 3.3 there are the values for parenting it to the motion controller. Does it help you?

Thank you for the link, I did not notice the pdf… that is strange on that particular one mine was out of align… It however is not when i put into a new project… weird. I am glad you will fix the finger…it is not much I actually used ue4 to scale it up, but it just wouldn’t save… I guess blender or such is required. Thank you for the link… I will read that: Well I read it… That made all the difference… I wonder what I did wrong to get that mess in the pic above. LOL I edited my review on EPIC. Thank you for being so prompt…

Ok So another thing I noticed is when I create a completely new project… and I add to project the scifi hands… it tells me they are already there, when it clearly is not. I will keep testing and posting here.

Right so I have been testing and the scaling issue I was talking about , presents itself when I swap out the mesh, and want to use my own animation blueprint…Do you have some kind of scaling in yours??? Try it … open 4.26 vr template add your gloves I use remastered 2, and dont even set a blueprint animation just keep it as none. its kinda small.

[USER=“637284”]Shao Lung[/USER]
the message that files are existing in the project already is because we have to include one file from the VR template. just click ok.

I have no scaling issues. maybe it is related to your animation - did you retarget any animation? you can try to modify these settings:

animation retargeting.jpg

As for the changes to the 3d model: I talked to my 3d artist. Due to the upcoming holidays here he won’t be able to work on it until mid of January or so. I’m sorry, but I ask you to be patient, please.

I made a video. so you can see…

thanks a lot! I’ll have this fixed, too!