Download

Hair Ragdoll Problem

Hey :smiley:
I’m not quite sure if this is a problem regarding the animation topic, but I guess here it fits the best:

So, I’m having a problem with ragdolling my characters hair.

0ed301d1b0b69353a843988b698c9f9a032749a8.jpeg

Here you can see all the hair bones that I want to be ragdolled.
Hair-ponytail-0 & Hair-ponytail-1 should remain kinematic (just like the rest of the model, except for hair-ponytail-2 to hair-ponytail-7)

Now, the problem that I have is this:

3DaqiSA.png

Her hair goes ingame straight into her backpack and then out. Why does this happen?
I tried to add more collision boxes around her backpack, but that didn’t fix it.

Any ideas? :frowning:

I recommend you to import a mesh with a horizontal ponytail for better physic detection, simulate each bones of this ponytail and adjust linear damping (higher values for the first bones)
I also recommend you to adjust physic options in your project settings for better results :wink:

Thank you, Nicobass for your help! The physics of the hair is definitely better now!
But my problem sadly was not fixed by this :frowning:

Everything is fine when I simulate physics in her physics asset thing, but ingame it looks like her second
(I discovered it’s always the bone after the kinematic set bone) hair bone wants desperately to get into her
backpack D:

physics test:
umaHrJh.png

ingame:
paeU4cY.png

I’ve set everything to your settings which I could see in your screens. Why is that happening? :frowning:

Perhaps the problem comes from your character’s blueprint, are you sure that your mesh doesn’t collide with anythings like the capsule component, a sphere trigger or any component?

Hair_Ragdoll4.jpg

I’ve been having the same problem since at least UE4.7. Collision of my pony tail chain looks great in the physics editor, but clips through the mesh when playing the game. I’ve created an answerhub ticket and asked on the forums about this issue, but never got a reply to this particular problem.

There used to be an additional issue that made the hair chain go completely crazy when the character moves. This was confirmed as a bug has since been fixed, which leads me to believe the clipping issue might be a bug as well. I’ll try to test it more thoroughly write a bug report this weekend.

Guys? My problem is still not fixed :frowning:
My set up is exactly the same as NicoBass’ but the ponytail of my Lara still gets dragged down!
Does anybody have an idea?
Please help me D:

don’t want to up this but…
UP

Please guys, I really need help with this bug :frowning:

Can you send me your project with the minimum assets?

It looks to me like the backpack doesn’t have kinematic collision. Each bone seems to have this collision (as it should), but the backpack doesn’t presumably because there’s no bone specifically for the back pack. That’s fine though since you could probably just expand the size of one of the spine bones’ collisions. Just enough to keep the hair away from the back pack.

To be honest, the clipping issue doesn’t look bad from the images alone in my opinion.

The backpack has collision assigned to it, and every bone besides the hair ponytails are kinematic.
I don’t really think you guys have got my problem, here is exactly what is happening:

In the Physics Assets tab, everything is flawless and fine working!
L0nSOTj.png

But when I go ingame or test the physics in the ThirdPersonBluePrint, the first bone after the
last kinematic bone gets dragged down like 10 centimeters or so.
2cwOXT3.png
Here you can see that her ponytail hair tie is way too stretched, since it is the first bone after
her head, which is kinematic.

I am pretty sure that this is not a collision problem, but more of a bug in Unreal Engine.
Does anybody know how I could avoid this bug? I have tried importing the ponytail as a additional
mesh but did not have luck with that either.
Any guesses? :frowning:

Have you tried to desactivate projection between yours bones in physic asset? (constraint mode)

Yes, I just tried that.
No luck, nothing has changed.
I have tried reimporting the model a few times, didn’t work either.

What am I doing wrong? :frowning:

Try the following and see if it works. Set those “kinematic” hair bone with angular limits as locked in phat(constraint mode) and disable gravity for it (body mode).

Apply a shape to upper spine for the Backpack collision?

loracraftbackpack_PHAT.png&stc=1

I already did that…
It did not work, the ponytail then just tried to get down that position even more.

why don’t you try to ragdoll the holder? sometimes simple things are the best

I fixed the problem. The problem was, that I hadn’t scaled my character the same amount on every axis. (XYZ)

I’m getting the same problem , my characters ponytail falls straight through her shoulders which looks ridiculous. In Phat however everything works perfectly. Another interesting fact is that it works well when I just put the character in a simple animation loop but not when I run the character as an Ai animation blueprint.
I’m glad Blech fixed his problem but I don’t see how scaling should have anything to do with this. One should surely be able to scale in any direction but still maintain collision?
Any help would be greatly appreciated.
Graham

I was having this same issue and resolved it by adjusting my collision settings on my character mesh. Try testing by switching is to from “Pawn” collision type to “PhysicsBody”. Then set it to custom and set it to ignore just about everything except PhysicsBody.