Gyroscope doesn't work in any way


I have tried to using gyroscope on my iPad mini 2 (iOS 9.2.1) but with no luck.
function InputMotion return zeros in all it parameters

PlayerInput->InputMotion(Tilt, RotationRate, Gravity, Acceleration);

A called it from functions ProcessPlayerInput and Tick in AMyPlayerController class.

Also I have tried this code:

InputComponent->BindVectorAxis("ActionTilt", this, &AMyPlayerController::OnTilt);
InputComponent->BindVectorAxis("ActionRotate", this, &AMyPlayerController::OnRotate);
InputComponent->BindVectorAxis("ActionGravity", this, &AMyPlayerController::OnGravity);
InputComponent->BindVectorAxis("ActionAcceleration", this, &AMyPlayerController::OnAcceleration);

Width these settings:


But is also returned zeros in all vectors while I moved my iPad.
All log messages about vectors data I have received through function AddOnScreenDebugMessage.

What I’m doing wrong, or is that a Bug?
Please help me with that.

Sitting in a similar boat here…
Only difference is that I’m on android…

This is trash…

I was having this issue and solved it but found the solution explicitly nowhere in the forums, only hidden in a random youtube video. I did stumble upon this unresolved thread however, so for the random 1-2 people who still struggle with this and land here (or future myself who forgot about it): In The Project settings under Android, then Input (Even in UE 5.0, but this goes way back) “Allow IMU Sampling” is disabled by default, which is Mobile Sensor Data. So tick that box and it will work assuming you use the correct node setup for gyroscope data.