Guide to use QtCreator for Unreal Engine 4!

In fact you have to remove all building step first then click on Add Build Step and select Custom Process Step wich is basically a way to tell to QtCreator that running a exe (or bat) is part of compilation process (actually in our case this is the only step)

I cannot for the life of me setup the build/run appropriately and would prefer you do a screen capture to better illustrate the method.
I can not find a working path entry field or a command entry field and have no idea where the launchsolo.bat should be called from.
also I cannot remove any default build options as the remove button is greyed out.

Please help a fellow out.

I made a little video of how mine is setup:

I went ahead and made a video going through the full Qt setup process following these instructions:
https://docs.google.com/file/d/0B0eV5r9stGxaMGpkQ2ZsTmh2REU/edit

Thanks and nice, you can add it to the wiki !

This is a lot of work you have put into this tutorial + the wiki, Antares!

Thanks so much for sharing!

And thanks to W1930U7 for making the videos!

:slight_smile:

Rama

Works perfectly!
Thank you very much

I’m unable to open the project, QtCreator complaining that there is no valid kit found. I do have both visual studio and GCC kits added.

Edit: turns out that because it is using qmake, which requires Qt libraries installed.

Edit 2: Using F2 on certain types don’t work. Example: ACharacter in my character header. When I navigate to USpringArmComponent header, OVERRIDE is not defined.

Edit 3: As it turns out, F2 works fine in .cpp files where the uber Engine.h header is included, but not in .h files. This is a bit of a turn off, as with Visual Studio I can still use Go to Definition in header files, without having to directly include relevant headers.

Thanks a lot Antares! I usually use Qtcreator and hence am very glad you provided a quick guide to set things up.
Yet, i have the same problem as Ethan who just posted before me: “intellisens” does not allow me to navigate through the “core” library. Somehow the global include of everything everywhere seems to be missing.

Is there a solution to this?

Thanks a lot in advance.

Thank you man. Works for me on Mac OSX too. Xcode just sucks when it come to big projects.
Everything works except to stop build process: I get message “The Process …Build.sh crashed”. But it is not so important anyway.

Are you sure that you have the defines.pri correctly include in your pro file ? In my project the every class works well, you can use F2 (or CTRL + Click) on OVERRIDE or any other class.

To be clear I have add all includepath that was include in Visual Project and all defines in visual project, there should be not missing includepath. But be sure to wait a little bit because OVERRIDE take a little bit longer to be detected in my QtCreator

Glad that you use it =) ! If I have time one of these day I would create a plugin for UnrealBuildTool that generate .pro files !

About your build process I don’t have a Mac so I cannot test it =/ I suspect that this is a issue with Build.sh, be sure that there is no problem about your modified version…

If you managed to do this, maybe you could try to push it to the main branch, try to get some official support for QtCreator. If this thread is any indicator, there definitely are people who would support and appreciate your effort. I’m guessing, as you hit on in your first post, there is a whole group of people who would be happy to not be forced into using VS / XCode if they had another reliable option.

I got it working first try, thank you very much! I’ve never used Qt before, but the parsing is so much faster than VS2013, it’s ridiculous. I’m so tired of sitting around waiting 1-2+ minutes for Intellisense to work at all when I make even the slightest header change.

Yeah but I don’t know when I may start ! I don’t think that this is realy complicated, just need to take some time to do some try with it.

@hsrob1: Realy glad that you discover QtCreator =), this is realy a great and simple IDE !

The thing i do not like is code formatting in header file because of macros like UCLASS(). It does not really work…
And build problems are only displayed in compile output.

Can it do debugging? That would be perfect! I cannot understand how MS can screw up with Intellisense so much, when other solutions can do it much faster.

I do get the macros like e.g. OVERRIDE instantly, as long as i include “Engine.h” in every header, yet when i look e.g. at “ACharacter.h” i cannot go on to APawn.h, when i do not manually add “Engine.h”.

Just started learning C++ and I had no idea what a nightmare Visual Studio is, so this is a lifesaver. I might’ve been turned off UE4 altogether otherwise, can’t believe we were practically expected to work without code completion.

Maybe a noob question, but does using this mean we always have to close the editor to compile?

I hope we will get official support for this editor because UE codebase is just to big for VS and Xcode…
It is hard to generate project every update self and includes need some tweaks like this part with “Engine.h”.

No. It does not.