Groom Physics Asset Collision issues

Anyone have tips on finessing collision between Groom hair and colliders on a skeletal mesh? I’ve noticed that scaling collider objects have no effect on the hair, but moving them does show visible collision behaviour. I tried re-creating a physics asset with convex hull for more accurate collision, but the groom seems to ignore collision completely now…

In 4.24 I was having the same issue, idk about 4.25 Seems like I solved it by changing the hair width to something larger. Also I noticed that there are issues with the groom not doing what its suppose to if you don’t export properly using the docs here XGen Guidelines for Hair Creation | Unreal Engine Documentation. I was taking a shortcut by not completing this maya script stuff, at the end and I think that was ok, for 4.24.2 but then they patched to 4.24.3 and it became necessary.

Thanks **ch0keh0ld. **Hair width doesn’t seem to have any effect for me - but I created my groom abc in C4D. I hadn’t considered that being an issue - going to test Maya instead.

So instead of testing Maya, I tried adding additional collider objects to the head of the physics asset. First time I did this crashed UE. So I deleted the groom asset from the skinned mesh and tried again. Voila. Scaling the capsules has no impact on collisions, but positioning does. For animation, this is a workable solution.

I know exactly what is the problem you are facing!
The thing is when you change any physical bodies rather than move them around, you need to uncheck the “Enable Simulation” box in the “Physics” Tab of your Groom asset and then check it again to take effect.