Groom not simulating physics but only in packaged game

Basically what it says, no matter what I do I can’t get physics to simulate on my groom components after packaging the project.

Viewport PIE, character preview, windows PIE, standalone all work fine, but once I actually package the game it stops working and I’m losing my mind.

Might this be a graphics card physics issue? How would you even go about trying to fix that? I don’t even know where else to start looking.

1 Like

I’ve managed to make a packaged project with just the third person example work with the groom.

So there’s an answer in here somewhere.

So far the only answer I have found to this is that you have to have added the actor to the level for it to be constructed at level load or else the physics won’t work in the packaged game.

So you can add the character to the scene, then possess it and modify it from there.

2 Likes

Thank you for posting the solution to this problem!

I’ve tried adding the whole actor versus adding a single strand of groom asset in the level, both methods seem to work (groom hair physics simulated without problem) in packaged game.

Hi, you can add the path of hair strand plugin content into the package project setting~like this:

4 Likes

This solved the issue for me. (Adding /HairStrands to the additional asset directories to cook)

I simply added this line to DefaultGame.ini

+DirectoriesToAlwaysCook=(Path="/HairStrands")

1 Like

Please help. When simulation is turned off, the hair groom looks fine but as soon as I turn on the simulation, the groom goes all up and stays there. Attaching the screenshots. Any help would be appreciated. I checked the collisions, skin cache but nothing is working. Its a custom groom from blender.