Groom Hair UE5 Early Access Glitch

Left side is UE2.26.2 groom hair, right side is UE5 Early Access groom hair.

Same hair, same character, same project ( copy of it in UE5 when I opened it there )
All settings are the same on the character and hair.
There is no wind or external forces at all
The hair in UE5 moves all over the place for no reason and then walking ( walk speed 120, not running ) it is like the character is going at a fast speed and the front of the hair is blowing back from the wind, the sides and back are all fine, however when running ( walk speed 300 ), then the hair is mostly fine, it doesn’t move like the walk speed hair does and reacts more like it would be on a real person. ( minus the hair sticking out like it does when the character is standing still )

1 Like

Hi,
Metahumans hair is funny also.
Running, jumping, start, stop, change direction, stairs and so on, make the hair have exaggerated movements.

Max walk speed 600

Max walk speed 1200 and 3600

After pass through a portal while running.
The portals just teleport to the other portal location in the same map.
The hair keep is offset in stand, walk, jog, run etc…

The unique way to get back the hair at is normal sate is to pass through a Portal again but at almost no speed.

thx.

2 Likes

Hi,

I really love Metahuman it is a real game changing, and it is easy to setup them as playable character.
But how keep the hair under control ?

The Metahuman hair when driving a car.

2 Likes

One way to solve this is using two groom assets, one simulated for normal character interaction - and one non-simulated used when driving.

… using non-sim groom for fast moving chars does not work like it did in 4.26, even with phyics sim. off the hair will offset when driving

In the Groom asset Physics tab, increase values of “Sub Steps” and “Iteration Count”.
Values 5 & 5 for those used to work in UE4, but similar result in UE5 requires value 10 on both in my case.

Hi !Did you fix it ? I have this trouble too . My character riding a motorcycle , and her hair look like your hair too when she moving . I try to find out how to contral Groom spring simulation ,but can’t get any detailed information about it .

This is the funniest image I have ever seen on these forums.

Also, yeah my character’s hair is completely crazy when walking. Makes the metahuman almost useless, unless I want to just make the character bald.

1 Like

Hello,
I am working on this for days, and I’d really appreciate your expert’s advice. I am getting very different hair simulation in UE4 and UE5. I import a groom asset in UE5.0.2 (Not EA anymore). I have enabled the two plugins “Groom” and “Alembic Groom Importer”. Furthermore, I have checked the “Support Compute Skin Cache” tick box in the project settings, just as the documentation said. But for the love of G*d I cannot get the groom on the head of the character without it spread all over like it’s colliding something. I am attaching 2 pictures. One is a messy UE5 groom and the other - a UE4 groom sitting nicely (it’s the same groom). It happens when I tick “Enable simulation” in the solver settings of the groom asset. Anybody else experienced that behavior ?


It works in UE4.27, but it spread weirdly in UE5.0.2.
I’d appreciate any lead.
Thanks and all the best,
Ido

Ok, So I figured it out together with the help of other users.
Basically, the problem is also discussed here :

Groom in UE5 is borked with motion, and level load times are insanely long - General / Feedback for Unreal Engine team - Unreal Engine Forums

So, the solution for me was :
a) Set Collision radius from 10 to 0.1 (that in itself is not enough).
b) Change the physical asset of my chracter so that the collision shapes will not stick out much.

I will attach a photo. One picture can speak a thousand words as they say.
Hope this helps.
All the best.


1 Like