Groom binding moves my hair up by 2 units

Hello, I’ve made a groom hair asset in maya and imported it into Unreal5, then created a binding and added the groom asset to a metahuman blueprint that I have, along with the binding. Everything looks fine, but as soon as I apply the binding to the groom component in the blueprint, the hair groom jumps up by around 2 units in the z axis, so it’s floating slightly above the head.

I created the groom in maya using the metahuman head geometry that I’m using in my BP, and it looks fine and in the correct position until I assign the groom binding (when it moves up around 2 units). I don’t know what to do about this, as there aren’t really any import settings for the groom, or settings on the groom binding asset for adjusting the transform position.

I had a similar issue in UE4, but I simply moved the groom component’s transform position down 2 units in the blueprint details panel, and that worked. If I try that in UE5, it doesn’t work - when I try to edit the component transform, the groom’s position doesn’t seem to change.

I’m really stuck and have an approaching deadline, any ideas?


Any suggestions at all? I found out that I can bind my hair groom to the body skeletal mesh rather than the head skeletal mesh, and this actually seems to attach the hair at the expected distance from the head (so it’s no longer too high). The problem now is that there’s a bone somewhere in the body skeletal mesh that distorts the hair groom whenever that bone moves (i.e. when the head turns).

1 Like

I am having exactly same issue.

You need the reference mesh and the target mesh when binding. When you create a bind, scroll down, there is another slot for the original mesh.
I have created a tutorial series (promo) Metahuman Creator Customization Tutorial (Promo video) - YouTube


I am following that exact tutorial. But I can’t get the binding to work…
I tried setting the original mesh as the source and the new one as the target, but the hair stayed in place.
Does anyone have an idea what could be the problem? I am using 5.0.3.

I’ve found someone said “delet all the capsule body except head and regenerate binding asset”.I havn’t tried this idea,and hope that can help you.

@samuelthomson have you ever found a solution to this?

I have created a custom groom in Maya with 100% the same metahuman model that I use in UE5.

However, in UE5, the groom is set 2 Units too high.

Simple solution for the following scenario:

  • Metahuman made with Metahuman Creator
  • Exported to Maya directly using Quixel Bridge
  • Groom made in Maya is up 2 units on Z-Axis when imported into Unreal Engine
  • Binding Asset is also up 2 units on Z-Axis

Sending Metahuman mesh to Maya with Bridge will result in a 2 unit offset on the Z-Axis on the face-mesh

Set Z-Axis transform of the face-mesh to 0 in Maya and re-export.
Groom and binding will align with the Metahuman mesh in Unreal Engine.

1 Like