Grass misplaced using Landscape Grass Type

So I played around with the new landscape grass type, and I really like it. Now I flew over my map and looked for any errors, and I came across multiple misplaced grass meshes. I tried to tweak the settings in the grass type editor, but nothing helped. How is it possible to disallow that?

I also have this problem. For one landscape component grass is just floating in air all the way to space.

Automatic systems will never do 100% of what you want.

I found best results in going in and hand painting out the erroneous spots.