Grass Mesh on Landscape not showing

My grass mesh is not showing on my landscape when I try to paint it.

Anyone solve this? Its rather irritating and peeing me off…

Are you trying to paint the static mesh to the landscape? If so then you’d use the foliage tool located to the right of the landscape tool then all you have to do is drag and drop the mesh in the relevant box in the foliage editor and paint it on your landscape.

According to the guide it automatically paints it, the foliage tool does work.
Or did I miss read the guide when everything had been “grassed” and it did not automatically appear without placing?

I have the same problem.

I have a Landscape Grass Type with a few different grass meshes. In my Landscape Material I have a Landscape Grass Output that uses my Landscape Grass Type and is hooked up to a Landscape Layer Sample that samples my Grass layer. I have my grass layer painted on my landscape. But there are no meshes anywhere.

What I don’t see here is the parameter for your grass node. So without knowing what you did I will try to help. I don’t think you assigned anything to the grass node.Left click on the grass node. In the left hand pain you need to assign something to your array. Click the “+” next to “array elements”. then in the spot that opens you will give it a name and then put the material in the box provided. I have attached a pic to show you what I mean.

264408-grass-node.png

First, try enabling “realtime” above the viewport options. I’ve discovered that landscape layer grass/decoration doesn’t display if the viewport is not set to realtime & a new map is loaded.

https://docs.unrealengine.com/en-US/Engine/OpenWorldTools/Grass/QuickStart/4/index.html
this helped me hope it helps you guys

for new guys: I think I found the solution: https://answers.unrealengine.com/questions/960645/view.html

Enabling ‘realtime’ worked for me thanks

For those of you still struggling with this:

Option 1)
Go to show (level editor toolbar)>advanced>CHECK grass.
*Note: this settings is unique to both game-view and editor-view, so it needs to be enabled for both (as one case was that the grass was not displaying in game view, but was fine in editor view).

*These view options are stored in the editor config and persist between editor re-loads.

Option 2)
Show (level editor toolbar)>Use defaults. This will set everything back to normal, which includes setting grass visible on game view and editor view.

for me it was because my editor is set to low scalability because of my old laptop. So it removes the foliage altogether.
although painting with the foliage tool did show the meshes but not showing the auto placement with the layer blending nodes.

1 Like