Download

Grass is Raytraced by default in 4.26 resulting in huge performance drop

Hi Joe!

Yeah, lot of people reporting performance drops on 4.26. I usually advise all people to send a bug report, so maybe they raise its priority: Unreal Engine Community

About ray traced grass, have you tried disabling RT for instanced meshes through command line?

Best regards!

A bug report is already submitted, and as was already discussed on this thread unfortunately the workaround you suggested doesn’t work, it disables raytracing on all meshes, not just the grass.
This bug is caused by a fundamental change in 4.26 to the way the engine handles grass and raytracing.

Hi Joe and everone else I tried the brushify grass with the dlss plugin from Nvidia and all my problems was gone. Still got som lag in grass rendering a bit slow when moving fast with camera but I guess that thats normal. Im on a RTX3070 full Ray tracing. I also used this console code from Nvidia. Something to do with foliage I guess. Got a lot more good looking grass with no performance drop.

  1. DLSS in Game: make sure that the following cvars are set
  2. r.NGX.Enable 1 (can be overriden on the command line with -ngxenable)
  3. r.NGX.DLSS.Enable 1
  4. r.NGX.DLSS.Quality -1

Hi all, I wanted to point out something new in 4.27 that should help with the problem reported in this thread. There is a new cvar called r.RayTracing.Geometry.InstancedStaticMeshes.CullAngle that enables solid-angle-based culling by default for ISMs, which includes foliage and grass. The default value is 2, which means that any instance with a bounding box that has a projected solid angle smaller than 2 degrees will be culled from RT effects such as shadows. Raising the number causes more instances to be culled. I tested the project linked above and the default culling behavior worked as expected. Hopefully this is helpful!

1 Like