Graphic driver Crash - AMD R9 380


So far I only read driver crashes on NVIDIA, so I’m unsure if it’s related to Unreal Engine Issues and Bug Tracker (UE-37999)

But I’ve been told to post my logs nonetheless (with -d3ddebug argument)

I’ve also included my DxDiag for complementary information. (interestingly, there are some issues related to UE at the bottom of the file)

So, i’ve been working on my project for more than a year now and stopped updating the engine since 4.10.
I decided to migrate to 4.14 about two weeks ago and recently started having stability issues, graphic drivers started to crash randomly when playing in editor (it never crashed when working though). No graphic drivers crash on 4.10 by the way.

Sometimes i could work for an entire day and not get a single crash. Sometimes it would crash a lot. A reboot didn’t help.

I updated the drivers but that didn’t help.

Crash would occurs in various situation, even as simple as just moving the camera around.

Also, when driver crash, i would get a little popup at the bottom right screen saying

“Default Radeon WattMan settings have
been restored due to unexpected system

for reading me

Hey Genova,

We have a ticket up for the crash with your specific stack. You can find the issue logged here: Unreal Engine Issues and Bug Tracker (UE-40807)

We still haven’t been able to reproduce this crash internally, but we will update the ticket as more progress is made. Feel free to track the ticket as we continue to investigate and review this issue. Keep in mind that we don’t have a time frame on when this will be addressed so don’t rely on a fix to be made quickly if it is crucial to development.



There is a possible workaround that we are investigating. The GPU crash may be related to microsoft’s Timeout Detection & Recovery(TDR) feature. You can find out more about it here: Timeout detection and recovery (TDR) - Windows drivers | Microsoft Learn

Basically, it detects if your GPU is hung up and if it passes a certain amount of time Windows will automatically reset the GPU resulting in the crash. This is done to prevent a freeze forcing a hard reboot of the system.

Sometimes you need to add a little more time for your GPU to process before Windows causes the reset. To do this you need to change the TDR delay.

I have two suggestion on how to do this you can do it manually yourself OR you can download a tool that will do it for you. However, I haven’t used the tool that much myself but it does appear to work. (Use at your own risk)

Method 1 (manually):

  • Go to the this link:
    Testing and debugging TDR during driver development - Windows drivers | Microsoft Learn

  • There you will find a section called TdrDelay it gives you all the information you need to create a registry key that will change the delay time

  • To open your registry open your start menu and type “run” once the window is open type “regedit” and hit OK

  • Now you should have Registry Editor open this is where you will use the info at the website I just linked.

  • First navigate the key path HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers

  • Right click on GraphicsDrivers and go to new> DWORD (32 bit) value

  • You will see a new key appear make sure to name it “TdrDelay”

  • Right click it and select “modify”

  • Under Value data enter 10 (this is the number of seconds to delay) make sure you have Decimal selected as the base

  • Hit okay and restart your system

Method 2

P.S. I know it’s an Nvidia forum however the tool should still be useful regardless of GPU type.

Hey ,

Thank you for your time and the explanations.
I tried the method1 and unfortunately it didn’t solve the issue.

Though I have new information, I remembered I had an old proto of my main system (a drag & drop of actors) and wanted to try it out. It crashes as well. On 4.9 … Which it never did, nor the 4.10.

So I’m back to square one: roughly at the same time I downloaded 4.14, something has changed on my machine which caused an instability with Unreal. I can play games no problem, even run furmark for some times without any hiccups.

Sorry for the waste of time and confusion regarding the main issue you guys have… But I have a question, when downloading the 4.14, could it has any sort of impact with the other versions? Some shared DLLs or SDK ?

It’s because you have updated your graphics driver, the new drivers from AMD (those that are called “Relive”) don’t work well with old GPUs like the one you have, so they are a bit unstable there.

You think so ?
Seems a bit coincidental. The crash appeared out of the blue when I installed and migrated to 4.14, and I didn’t update the graphic drivers right away.
But i’ll try to roll back to an older version. Any recommendation?

Hey Genova,

We are currently unsure what has changed in 4.14 to cause this crash issue. It is pretty wide spread so I think that it isn’t necessarily something you did. You definitely welcome to try different drivers however in house testing suggests that this issue spans across several driver versions.

Also, downloading new engine versions will have no impact whatsoever on older versions. They are contained within their own directory and are precompiled.

[EDIT] A user(IronicParadox) suggested that going into the content browser pane > click the little eye that says “View Options” and uncheck “Real-Time Thumbnails.” made the engine much more stable.

Let me know if that helps with stability.

I will update this post once we have more information.


Hey Ed,

Unfortunately, disabling the realtime thumbnails didn’t solve the problem.

Here is another thing I’ve seen users post on other threads.


Create a shortcut to UE4Editor.exe. Edit the shortcut’s properties, in the Target field add the -opengl4 flag:
Target: “C:\Program Files (x86)\Epic Games\4.14\Engine\Binaries\Win64\UE4Editor.exe” -opengl4

Source: here Thank You: Gereksiz

Unfortunately, this will remove some rendering features and some materials won’t work in this mode. Only use this as a last resort.

Hello Ed,

Great news ! I think I found something that almost eradicated the driver crash on my machine (I say almost because while doing my tests I still got one, but that might be a mistake I did, or related to another issue)
While looking for this kind of issue here and on AMD forums/reddit etc. I saw several posts regarding DX11/12 stability for R9 380 video card on Win10, and I thought I could give it a try.
In the project properties, there are no options for DX12, only for DX10 and 11 (does it means DX12 has yet to be officially supported ?), but opening the project with -DX12 argument in the shortcut is supposed to enable it and that seems to have fixed my issue.
Worked several hours, stress tested it and no crash. Now, that doesn’t mean it won’t happen again, but that looks way more stable now.

tldr : adding -dx12 argument in the shortcut enables it, which makes the engine more stable in this specific configuration.

for the update. I’ve informed everyone investigating this issue. I’ll update this thread if any notable progress is made.

Actually it’s not totally fixed, today I got several crashes in a row. And then it stopped.

Also, to minimize risks, instead of having the editor on one screen and Blueprints / PIE windows on another, I only use one for now.
I don’t know if that helps, but it’s way way more stable than before. (but again, since it’s quite random, it’s quite hazardous to assume anything)

I used to have the same issue on a different amd card but it didnt only affect the engine, it affected games aswell. I tried every possible solution including some mentioned above but it finally turned out to be a overheating problem and I had to get a new card. And on my newer card which is the same as yours (r9 380) it does happen but not as frequently, maybe once/twice in a week.

But I also started getting the same crash when I tried to add decals to my level, I thought it was a UE4.14 issue as well but rolling back to a much older version of my drivers resolved that issue so maybe you can give it shot, try rolling back to the February 27 (2016) Radeon crimson drivers.

Hey !
for sharing the info, I’ll try that tonight !
I already checked the temperatures and everything is normal, I even ran Furmark stress test without any issues.
I’ll try the oldest drivers and post back.

So i tried the 16.2.1 drivers but quickly changed. They had a problem with GPU fan control, and running unreal quickly raised the temperature to 80°c
I grabbed a more recent one, 16.4.2 (WHQL) but that didn’t prevent unreal from crashing.

: Is there any debug tool I can install, or some kind of remote debugging we can try to figure out what’s going on? I feel like I won’t be able to get a stable environment any time soon, and to be honest it’s a bit depressing.
So I was wondering if you guys had any way to use my situation to collect more reliable data on the issue.

@ : can we keep the thread as unresolved please ?
The issue is clearly not, and if someone with a potential solution sees it as resolved, he might not stop by to drop it.