Graph is linked to object(s) in external map, cannot play in standalone game

Hi ,

Have you been able to recreate this in a blank project with no additional content? Thank you!

I can’t run my game in standalone mode because I get this error

Can’t save
Graph is linked to object(s) in
external map. External Object(s):
/Engine/Transient Try to find the
chain of references to that object
(may take some time)?

every time it tries to save this blueprint. The strange thing is that if I try to run it in editor it works without problems.
Since this is the 3rd time that this has happened I tried to recreate this blueprint from scratch, resulting in the same error. I can’t figure out what exactly is causing the problem.

Hi ,

Could you please provide images of the graph for us to reference. This will allow us to see a bit more about what may be going on. Thank you!

I had a similar issue and I was trying to Load some settings from a saved file in the Constructor part of the Blueprints. After I moved it to the Graph part it all worked fine.

In my first defect BP I tried to add a dynamic material to the skeleton mesh in the construction script. In my current try the construction script is empty.

until now I was unable to recreate this in a black project. But each time I open this blueprint it breaks more and more

Reparenting to actor and back to character helps with this but it won’t fix the external reference. After that I am able to at least use PIE

I noticed that my log has line like this

LogActorComponent: UnregisterComponent: (/Engine/Transient.FloatingPawnMovement_4) Not registered. Aborting.

in it and that is my only hint to a reference to /Engine/Transient

are screenshots from all functions (without interfaces)

That is all there is in this BP.
At first I thought that the skeletonmesh was damaged so i re-parent to defaultPawn → same problem. Maybe the custom enums are causing the problem. After I deleted the Team variable I was (once) able to package my current game to windows (play standalone from the editor still crashed). I readded the variable and reconnected all nodes and the build failed again. So I deleted the variable again but this time the build failed too.

link text

is the cooking log if that helps

Ok I found the cause of the error but still don’t know why it is causing the error.

In order to get a working BP again I had to:

  1. Reparent my BP (character → actor → character)
  2. Delete the Team variable (custom enum)
  3. cooking → ok

If I now readd the team variable without connecting it to anything the cooking still works. If I then add the “set Team” as seen in s3.png and connect the team variable to the none slot seen in s2.png the cooking fails.

Now the question what is wrong with this enum ?


It is a BP only project (as long as I can achieve my goal)

Hi ,

Is your project entirely in Blueprints or have you provided any C++ code to it as well? Thank you!

Hi ,

Have you been experiencing this since the latest patch went through? Please let us know if you are still experiencing this bug. Thank you!

I don’t use/have blueprints in my project at the moment. Because of this bug I decided to rebuild my foundation in C++ and try BPs again later.

I had a problem similar to this. I found that I was unable to save out my blueprint and received a similar error. I was creating a derived UObject in a C++ class. Such objects are destroyed by the garbage collector which tracks them via the UPROPERTY() tag. I ended up with something similar to this in the class storing a UMyUObject pointer:

UMyUObject* MyObject;

Unfortunately, the problem arises when you have an empty UPROPERTY declaration which is private. When you attempt to save out the map, you’ll find that it throws a wobbler when attempting to reference any private properties not marked transient. You won’t have to have changed the asset for this to happen - just the scope of the variable in the C++ class.

The solution in my case was to mark the property as transient.

UMyUObject* MyObject;

One extra thing… When the warning dialog appears, it actually displays a list of privately referenced objects. Engine/Transient is just another private object that is used internally. Engine/Transient won’t cause you a problem on its own. You only see it if your own property is broken.

Don’t know if that’s relevant or related to your problem, but I found this topic whilst searching for a solution to mine and someone else might too.

I have this bug 4.6.0 - 4.6.1

Hi ,

Does this occur in a blank project with no additional content? What steps have you taken that reproduce this effect?

I have a diferent bug thread on answer hub, but its not exacely the same thing and it was do to bad refrences in the Blueprint/ WIdget.

I have been having this bug for multiple weeks now. Every time I a create a project and start doing stuff in it, the error will eventually pop up the next day or so. No solutions from the web have helped at all. Please fix this, Epic. It renders the Engine as unusable for many people, including me.

Hi Devfo Studios,

Are you using any level streaming/world browser content in your levels? If so, are these being referenced by your blueprints/level blueprint?