GPU prioritization for multi-GPU Setup going wrong when working remote

Hi,

my office setup has two different GPUs, a 3070Ti + 3090.

When trying to work remotely, the Windows Remote Desktop Service is grabbing the 3090 to run on, which leads to unrealeditor being run on the 3070Ti. This of course is all backwards.

In the NVidia Control Panel i already specifically set the remote desktop to use the 3070Ti and unreal to use the 3090 but windows just keeps ignoring it.

If somebody has an idea if there is another way to set this up i’m all ears. Maybe this is even the right time to set up pixel streaming?

There are a few things you can try to get your GPU assignments to stick:

  • Try using the Nvidia Control Panel to assign a specific GPU to the Remote Desktop application. This can be done by right-clicking on the Remote Desktop icon and selecting “Run with graphics processor” and then selecting the desired GPU.
    bild
  • Make sure that the Remote Desktop application is using the correct GPU by checking the GPU usage in the task manager.
  • Try using the “Nvidia Profile Inspector” tool to assign a specific GPU to the Remote Desktop application.
  • Try using the “Nvidia GPU Activity” tool to see which process is currently using which GPU.
  • Pixel streaming is a solution that can allow you to run the Unreal Engine on your office computer and stream the output to your remote device. However, it requires additional configuration and setup, and might not be the best solution for your use case.
  • You can also try to use the GPU Pass-Through to assign the GPU exclusively to a virtual machine that you will use for your remote session.
  • Some users have reported that disabling the RemoteFX feature in the Remote Desktop settings can resolve the issue.
  • You can try to disable the “Windows Graphics Composer” service on the remote machine as it might be causing the GPU assignments to be ignored.