GPU Particles & Mesh Distance Fields

As shown in the screenshot, I added a simple cube from the modes tab to the effects demo in 4.10, in particular the GPU particles example. The particles are set to use ‘Distance Fields’ and the project ‘Generate Mesh Distance Fields’ option has been enabled.

Although the (working) demo shows particles colliding with the silver spheres, they pass right through my simple cube.
I have also tried setting the cube’s ‘distance field resolution scale’ at 3, 10, 20 but it makes no difference.

Why is the GPU particle system behaving as if there is no mesh data for the cube?

Hi Ash22,

If you’ve non-uniformly scaled the mesh that you’re using then this will cause the particles to pass through. Also, if you use the Build Settings option for Generate Distance Fields as TwoSided will ignore collision as well.

Try using the Basic Cube mesh from the Modes Panel and only scale uniformly to see the distance field collision for the particle system.


Thanks Tim, good to know.