Gpu particles issue in 4.7 release?

This post says that gpu particles is supported in 4.7 release for metal enabled ios devices,however,I failed to see it working on my iphone 6 plus.I just migrate the gpu particles from the content example->effects level.
Any settings I am missing or it is a bug?Thanks!

Howdy ,

Thank you for reporting this issue. I have tested out this issue and have been able to place a particle system into my level, deploy it to an iPhone 6 plus, and see the particle system without any errors being present. Would you be able to clarify what asset you were using exactly when you were testing this issue?

I was using the P_electricity_arc.uasset. I did notice that if you go directly behind the particle system you are able to see errors. Here is what i currently see:

One is showing fine as long as you are in front but the other is producing an error when behind it.

Any additional information would be greatly appreciated.

Thanks and have a great day!

Thanks for testing it for me.But I mean GPU particles(particles having a gpu module) not this beam particle.Gpu particles don’t work on mobile.Although the post says 4.7 supports it.

I’m interested in the answer to this also. I tried to test GPU particles for an iOs 8 build and they didnt show up.

Howdy and ,

Thank you for reporting this issue. I was able to replicate what you have been seeing by placing a GPU particle into the a blank project. I have entered report 11067 into our bug database so that the issue may be resolved in a future release. Let me know if you have any more questions regarding this issue.

Thanks and have a great day!

Hey and ,

I have just seen that the report that was submitted has been marked as fixed for the 4.8 release of UE4. It is still in testing to make sure that this can be closed, but a fix has been put in. I will be sure to update you as I know more.

Thanks and have a great day!

Just wanted to keep you both updated. UE-11067 has been pushed back a bit further as it is going to require extra testing and will need to be rewritten. I will let you know when I see any additional information on this issue.


Hey , could we get an update on where GPU particles are at on metal enabled iOS8 devices? This would be an excellent feature for my simple mobile app that I’ve been working on. :smiley:

Hi PaladinDawnfire,

The fix for this will definitely not make it into the 4.8 release, I am sorry to say. However, I have reached out to the developers who are working on it, to see if they might be able to get the fix into 4.9; that is still being discussed. I will definitely update here when I get more information about the status.


Hi , Are there any updates on this? I’ve just tried it on preview 4.9.2 and I can see the sprites in editor, just not on my . Thanks Rob


This issue is still being looked into, it’s on our ‘to do’ list and it’s not resolved at this time. We realize it’s been quite a while since it was originally added into , since it has a priority of 3, those priority 2 and above will come before this specific issue.

If you have any further questions, please let us know. Have a wonderful day!

I know it’s only been about a month since this reply was given but we think about release in December and we really need to be able to use Particles. What’s the status on this problem?


This issue is assigned to a Developer however it still has a status of ‘to do’ therefore, it hasn’t been completed yet. I made sure to comment on the so they’d be aware of the public asking about this bug.

Let us know if you have any further questions, thanks!

With UE 4.12, it was announced in the patch notes that GPU particles are now working for A8+ devices (iPhone 6 and up) as well as Android phones with Adreno 4xx and -T7xx GPUs. I have tried using GPU particles on a new side scroller project I created to test this feature. When deployed to an iPhone6 Plus, I am still unable to see the particle system. Could someone from QA test this feature for me again and confirm that it is working?

Thanks Epic! :slight_smile:

Still waiting for an answer to this, could someone check this out for me?

UE-11067 has been fixed in 4.12, so it should be on any build 2920981 and higher for the changelist.

understood, but could you try and repro this to confirm? I’m still not able to get GPU particles working on the iPhone 6 Plus.

I tested this on an iPhone 6 Plus and the GPU particles appeared. It could be how your particles are set up? If you feel that is the case, please submit a new AnswerHub post in our Rendering section.