Download

GPU overheating during material creation.

My GPU is overheating after I create so many materials, I don’t know the exact number but it’s low. Once I reach the “limit” my computer ramps up and the GPU goes into nuclear meltdown. The materials are not very complex and like I said the number of materials created is pretty low. The specs of my PC are as follows, GPU: r9 290x 8gb, CPU: fx8350 8core, ram: 16gb. The textures are coming from Gametextures.com. I’m not sure why this is happening. Any suggestions would be helpful.

Make sure to update your drivers

Does this happen with any other applications/games? Does your case have proper airflow?

Remove dust from GPU cooler and air ducts on computer case.
Monitor GPU temperature once you’ve done that. If it still stays at high values (70 degrees and above), then you’ll either need to replace thermal paste on gpu’s heatsink OR you need better GPU cooler.

Yup you should dust off all fans, at least every other year.

If you have “soda stream” at home (or some friend has), some of their devices have removable head, and that stuff is best dusting off solution. Just watch water condensation and not overdo.

I did not have ATI since 9700pro, but this stuff may be also on ATI’s.
Some drivers keep GPU fans at minimum, and they approximate temperature. When you all of sudden start using everything poor GPU has (like unreal does), it gets hot very fast and your fans are set to ~10% speed until temp goes above 60C, then they go 90%. There was riva tuner (again Nvi8dia, not sure about ATI) that let me change how metal fans behave. So i set it to increase lineary, from 30C to 60C then fixed 100% above 60C.

Ps. Rivatuner works for ATI and NVIDIA, also Catalyst control panel has metal fan control forces and capabilities so make that fan spin at 40C. (or find temp for when you are in editor, add 5C margin, then when temp is above make them spin 100%)

Other simple solution is the “MSI Afterburner” Software.
Have the same model of GPU and solved ALL my heat problems.

:smiley:

Thanks for the advice, although my PC does need a good dusting it’s definitely not the issue. I can play for hours on end at 4k resolution with no problems. I believe it’s due to the creation of too many materials. Instead of making a master material and making instances from that I was just making materials. I haven’t tested that out yet but that is most likely the problem based on what I’ve seen in other posts.

I Suggest turn off live preview and click apply manually whenever you change the material logic, otherwise it’ll try to compile and load each time you do anything while editing the material

Yes, I did see this in another post and changed it. I noticed a significant boost in speed, things happen much faster with it off. I don’t think it’s necessary for me but I’m leaving it off just for the speed increase.

Just to confirm, it was too many materials. I made parent materials and instances from those and the overheating stoped.