Download

GPU Laptop 3080 not working on UE Editor

I’am having this weird problem… I just got myh scar strix with laptop a nvidia 3080 and it works like a blast on everything, besides Unreal. Everytime I open the editor it switches to the integrated graphics and doesn’t use the proper GPU. I’ve tried everything I could find so far, adjusting it on nvidia control panel to force using the nvidia card, both to all apps, to the editor.exe and to the whole engine folder. I also forced it on Windows Graphic settings for the editor.exe. I have all the drivers up to date and evem tried to disable the integrated graphics… but that haven’t worked either… Does anyone have any idea on what else can I try?

Solved:

Had to do a clean reinstall of all NVidia graphics and rolled back to an older version.

In the Nvidia Control Panel, you can’t simply assign the Nvidia GPU to run the UE4 editor, you need to set it as the global default (to where it doesn’t use the Intel GPU at all)