GPU Crash 4.26 and .27 with Raytracing settings enabled

Hi Everyone,

In Unreal 4.26 and 4.27 unreal keeps on crashing after around 5 to 10 minutes and I receive the error d3d device removed. In the error screen after the crash it is related to RT12.
I came across more people with the same issue’s and the recommend a few options:

  1. Using Nvidia studio drivers - Check
  2. Reinstalling nvidia drivers - Check
  3. Reinstalling UE4 - Check
  4. Changing the TDR delay to 10 seconds - Check
  5. Not using programs like MSI afterburner - Check
    Even with these options done I keep running into the same problem.
    The strange thing is I don’t have any issues with UE5 what so ever.

Anymore tips on tackling this problem? Thnx in advance!


have you received the answer you need? If you have, please share because this is also the problem I want to solve


Not yet unfortunately. Will keep you posted, if I here something.


What’s your GPU?


Asus TUF 3090


In that case it shouldn’t be crashing, is it a default scene? If not is there any features that you’ve used or anything else that might impact the graphics that might not be properly supported with ray tracing?

A new studio driver got released today and that seems to have fixed the problem for both version .26 and .27 :slight_smile: Have been using both for some time and both seem to be stable again. The crashes where random in both versions.

@shayleelindgren see if this works for you.

Which version number driver do you have? I’m running into the same issues.


I’m using studio driver version: 471.41


I also had the same problem using an RTX 2080 card.

Hi all, I am having the same issue. Once I enable ray tracing UE crashed IMMEDIATELY a second after with the GPU crash error warning.
I installed UE again, updated drivers. Nothing helped so far. Anyone knows how to solve it?

(I have 3 x GTX 1070)

The GTX 1070 is not a good card for ray tracing, it won’t be able to run the game at a playable framerate with ray tracing enabled. Your crashing issue could be due to the 3 cards, the engine doesn’t work with SLI enabled, though if you really want to you can work with Nvidia to support SLI with your shipped game.

For anyone else on a 3090, currently havong an interesting fiscussion with Nvidia as this is happening again on Game Ready drivers.
Hopefully they’ll be patching stuff specifically for win11 with the next release.
The d3d device lost message isn’t consistent at the moment.

Thank you for the answer!
Ok, did not expect that. I always work in other software with pathtracing and my cards work perfectly fine with that. But seems to be a different process then.

I only want to use UE for design development, not gaming actually. So maybe I try it without ray tracing for now.
Which cards would you recommend for ray tracing though?

Usually GPU renderers allow you to use multiple GPU’s without having them set to SLI, you’d just need to have SLI disabled when you’re using UE4.

For ray tracing, the best option is a more recent RTX 3000 card, but they’re hard to get right now.

Is that document for all GPUs or only UE5 GPU?


TdrDelay Section help me
Hope helps you tooooo

I think it’s different for all GPU but we need to check it.