Download

GPU/CPU usage control

Hey!
I’m fairly new to unreal engine, but as I was looking for editor preferences I didn’t find option to limit frame rate on editor window?
any attempts to limit it outside the editor are not working(forced v-sync, artificial limit from dxtory or similar).
edit: scrap that, just have to go sub 30fps to get usage down to 70% using single GTX 680

Now some might wonder why is this a problem, so let me explain:
High-end CPU/GPU consume a lot of power at full usage%(unlimited framerate), and when you work with UE for 6-12 hours a day the electricity bill starts to pile up.
Not to mention during summer it’s really uncomfortable to sit in the same room with that computer due generated heat(for measure, exhaust air is around 60C/140F degrees)

So I’m wondering is there way to limit it, or could this be a possible feature in the future?

Hmm, I already use all power saving features. If you set in 3d control in the Nvidia control : power usage to adaptive your grafic cards clockwork should be adjusted to the needs of the program. To further lower power usage you can use a program like EVGA precision and set the desired FPS to 45, so now the GPU won’t go calculating FPS that is not needed to play. I use 45 FPS on all my games and have no issues at all, even micro stutter get’s worked away like this. You can activate v-sync simultaniously to, so no problems with stripes and artifacts either. My cpu is automatically adjusted to the needs of the system to, so by setting the framerate down for your grafics card you also lower CPU usage ! For your heat problem you can adjust the vent on your GPU with the precision tool.

yea, Actually I was hoping more like a feature on editor where you could control the frametime during editing and then remove the limiter once you hit play or simulate.
That way you don’t waste power on updating still image at rapid rate when you are working with, lets say blueprints…

Oh, you mean a built in feature. Than you will have to wait for Epic to respond I presume.

You can do that by disableing “Real-time” in viewport options

huh, never noticed that one. Thanks!