Download

GPU 75% on game shiping build

i have a simple 2d game and its realeased on steam and the game receved multiple review about gpu being at 100% for certain person i got 2ms in the gpu visualizer could anyone help me i dont very understand that.

ps: all my blueprint is check for (tick event) and once called its only use (do once) node so the problem dont come from there



The do once node actually checks for 2 booleans every time it’s called.


this could cause problem? (there is 9 event like that below)

but in the gpu visualizer this is post process problem not (tick)

Try enabling Vsync.

putting so much stuff in event tick is generally not good even tho it’s not related to ur problem here.

will this work on packaged game with this? on the defaultengine
when game launched i saw small difference but there is post process
[SystemSettings]
r.Vsync=1

I think your logic might be a little ropey there. If any of the bools are false, each stem it called every tick.

If it’s on Steam, you can patch it.

It may do. However, I do this on BeginPlay in my GameMode. It sets resolution, full screen mode and vsync. It works in packaged shipping builds.



here the new value once the game launched its about 40% now
it is possible to have 0ms for post process?

That’s good. In theory your gpu usage will have gone right down. Just remember to turn it off if you are profiling… Game should run smoother without tearing now too.

You could test disabling stuff below in project settings->engine (ignore what I have set/enabled). Also enabling forward render may be a performance win if you don’t depend on any deferred render only features. You can also choose to enable MSAA anti-aliasing with the forward render which looks nice.
image

Capture

i think you just resolved my issus with vsync!

Superb! Glad I could help. Best of luck my friend!