GoogleVR iOS Crash After Launch 4.15, 4.16

I can’t run the game on iPhone, when it is packaged Shipping with GoogleVR plugin enabled. It just crashes after splash!

I tried 4.15 version - crashes. 4.16 - the same. 4.16-googlevr source build - crash too.

When I disable GoogleVR plugin - the app runs and all works fine.

I use remote build with PC and MAC, also I tryed to build from only Mac - the same result.

In Development build GoogleVR plugin works well! But Shipping (doesn’t matter with or without distribution flag) application crashes after the splash appears.

Does anyone here has the same problem?

What else can I try to make it run in Shipping builds?

It is a very big problem for me, because I can’t hand over the project to the customer, and I even don’t know when and how this issue can be solved…HELP!!

Make sure you are on 4.16.2 since it had a few ios fixes.

Try turning off Blueprint nativization?
Project Settings > Packaging > Blueprints > Blueprint Nativization Method: Disabled

Also try turning off Event Driven Loader
Project Settings > Engine Streaming > Package Streaming > Event Driven Loader

Both of those are newer features that are great for performance but seem to be a common cause of crashes.

Also are there any warnings or errors output in the device log of your phone when you are running debug builds? They could be causing you problems in your shipping build.

Geliott, thank you for advice, but it still crashes.

Yes, currently I use 4.16.2 for this project.

Nativization turned off, Event Driven Loader is off, unfortunately, this did nothing in crah case.

I took crash log and runtime logs from xcode, they are in attachment.

What I think can be valuable:

ShippingLog: [186] Jul  6 10:18:55 iPhone-Daniil SpringBoard(KeyboardArbiter)[212] <Error>: HW kbd: Failed to set (null) as keyboard focus

DevelopmentLog at nearly same state [395] doesn’t have this error.

Internet searching gave me, that the error “HW kbd: Failed to set (null) as keyboard focus” appears on different applications and causes crash too.

It seems, that the crash is somehow connected to iOS system keyboard/touch events. I point one more time that it happens only with GoogleVR enabled, something in the plugin works in wrong way…? Or engine conflicts with something in iOS? I looked at GoogleVR plugin source code but couldn’t find anything that touches keyboard or touch events in iOS.

I have the same problem, using 4.17.2 (Same as 4.15 and 4.16) the game crashes after the splash screen.
It is suposed to work, I’ve been digging and there is a lot of people complaining about this. I did a debug build (The debug build works) and resigned It with Appstore mobile provisions but when I upload the app It says that the executable size is over 60 mb.
The shipping build directly crashes after the splash screen.
So now I have an ipa that cannot be submitted and another ipa with an executable size lower than 60 mb that doesn’t works.
My client is completely desperate, I have been trying to make this works during weeks (Weekends included), you at epic should at least advice in the documentation that the googlevr support on iOS is tricky or beta or experimental or simply doesn’t works, so the people can reconsiderate about using unreal for mobile vr development.
Please if someone managed to make this work please share the magic steps you followed to make it work.

any progress on the issue? stil crashing on Black Project with Google VR Enabled

Still crashes on 4.20… any help?