Google VR IOS Shipping build, crash after splash

Any ios shipping build generated with Google VR plugin enabled, came out damaged.

Splash screen start, and then the app close.

It looks somewhat related to Arm64, because developer builds just works fine, and the only difference, apparently, seems that developer builds are ArmV7 enabled by default.

Tested 4.14.3 and 415.0

I had similar symptoms when I built my app for Android with third-party plugin enabled. Please check in your project if all unused plugins are disabled.

Hello jined,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints/settings that may be involved with this issue?
  4. What device are you currently using when you have this issue?
  5. What is the current OS being used on the device?

MACOS 10.12.3

iPHONE 7 10.2.1

  1. Install unreal engine 4.14.3

  2. Start a new blank project (i.e. First Person Demo), mobile, scalable, no content.

  3. Plugins/Virtual Reality, remove all, activate Google VR, restart project

  4. Project settings: package for SHIPPING, enable compressed cooking

  5. IOS settings, create package demo.firstperson.com, options enabled:
    Package for iPhone only. All other options left as they are.

  6. Registering new app id demo.firstperson.com, generating developing certificate, and developing provisioning.

  7. Get back to Ue4, project settings, import the provisioning and certificate.

  8. Build for IOS

  9. Open XCode, push the .IPA package into iPHone7

  10. Run the app FirstPerson, the splash screen start, then immediately, the splash screen close.

All the same, but DEVELOPMENT package, and the app starts normally.

If in development build, activate both ARM64 and Arm7, in IOS options, into project settings, and also the packaged Development IPA, crash after run.

Any idea?

I was able to reproduce this issue on our end. I have written up a report and I have submitted it to the developers for further consideration. I have also provided a link to the public tracker. Please feel free to use the link provided for future updates. Thank you for your time and information.

Link: Unreal Engine Issues and Bug Tracker (UE-42339)

Make it a great day

This bug does not seems to be resolved, even in 4.16.0

This issue was marked as a duplicate of UE-41244. I have updated the public notes to show this change.

Link: https://jira.it.epicgames.net/browse/UE-41244

Got this problem too, did anyone resolved this? I am using 4.16 version

Hello mister_dan,

I do not have a workaround for this issue at this time.

UE 4.16 - Development builds run well on iPhone 5s with both armv7 and arm64 turned on, but Shipping builds still crash after splash

I got this problem too. using 4.16.2.
Shipping builds crash after splash.

Build OS version: macOS 10.12.5

Testing device: iPhone6S (iOS 10.3.2)

Why is this issue marked as a duplicate of UE-41244?
I think this problem is more serious than UE-41244 because we can’t publish iOS app using GoogleVR plugin.

I have posted a question in bug reports about it: Crash on iOS after splash with GoogleVR plugin enabled - Mobile - Unreal Engine Forums

So, i hope we’ll get some new information about this bug, and I hope it will become “actual” from “duplicated”…

And yes, there is quite a workaround to publish development and re-signed version, but it is not good anyway.

So if it is VERY important for someone to publish the app “RIGHT NOW!”, there is a working case: make dev. build, turn console by 4-tap off, resign ipa with distribution certificate and load to appstore. But the size will be very big. I made it for my project, because couldn’t wait anymore. For iOS 8 app should be less than 100MB, iOS9 < 400MB, iOS10 <2 or 4GB…

Do you know what script settings to move? Very interesting for me, because I tried different methods for 2 weeks with no success.

Any workarounds yet?

I found, that the crash is somehow related to this iOS system error: “SpringBoard(KeyboardArbiter)[212] : HW kbd: Failed to set (null) as keyboard focus”

I made a new post and added crash and runtime logs for details. Maybe it can help.

The log from Xcode tells, that crash connected with this error:
ShippingLog: [186] Jul 6 10:18:55 iPhone-Daniil SpringBoard(KeyboardArbiter)[212] : HW kbd: Failed to set (null) as keyboard focus

And it appears only with Shipping build and GoogleVR plugin enabled.

And I fully support hirapong: UE-41244 seems to be a different to this issue, especialy, UE-41244 - seems to be solved, because there is no crash with Switch button in UE 4.16.2

Correct, this is a serious bug and was introduced by 4.13, and yes, it is not related UE-41244.

Publishing is indeed possible with a workaround in v4.16.2…as long as it generates, working 64bit development/debug builds, some users managed to rid, moving many ios compiling script settings of the debug version, to the shipping version… but would be better, that shipping builds with Google VR enabled, would not crash.

Manipulation of compiling scripts may lead to unexpected results and probably not properly working .ipa’s

Yes, i’ve read somewhere that users moved ios compiling debug script settings, to the shipping script to get working ipa’s with GoogVR enabled.

Development/Debug builds works quite well for testing, but they are not good for publish for a series of reason, including a different management of the provisioning that generates upload errors in the Application Loader, and last not least, presence of some Unreal tools and libraries for console command and debug purpose, but also the console command itself.

Development builds have several cooking compression disabled, you may turn them on manually, and solve the size problems. Indeed, publishing development builds it is not yet the right solution, so we should push the team to fix this issue…