Google Play services removes the leading zeros for .obb file

I am getting an error message when my project is uploaded and published in alpha for google play (.apk + .obb). The file downloaded matches the .apk and .obb size, but when downloaded through google play it refuses to play, while the same .apk and .obb, when deployed to the phone via the batch file, work perfectly.

The exact error message I am getting is “Failed to open descriptor file ‘…/…/…/ProjectName/ProjectName.uproject’”.

What am I missing? Using version 4.7.1 .

I noticed that the .bat files installs to folders inside the root of the phone while the appstore downloads it to Android/data and Android/obb. I tried downloading the TappyChicken from the playstore and it does indeed manage to extract itself to the root from the Android/obb and leaves it empty. I also saw an installing after the tappychicken download completed. Is that what I am missing? How would I go about doing this step.

I Built TappyChicken and I get exact same error. It works fine running from .bat file, but when uploaded to alpha on google play store and installed from there exact same error. Even upgraded to 4.7.2 and still same thing. Any help would be much appreciated.

Hi BaderThanBad,

We are in fact looking into your issue. I am checking with the Android dev, and it is possible your issue may be related to a problem we’re investigating involving obb location and the Google Play store. So hang tight a little longer, and I will report back with anything he finds. Thanks very much!

I think I found the issue (still waiting for google play to publish to confirm). In the engine’s AndroidLaunch.cpp file (in the initialize function), it assumes that the obb file’s name has 5 digits with leading zeros. Google Play services, when you upload the .obb, removes the leading zeros causing the discrepancy. I believe a temporary workaround would be to use a 5 digit (non leading zero) version number and was going to file a bug report after I have confirmed this. The apk is yet to be published so I cannot confirm anything but please pass along this info may it help.

Noted! Thanks for the info.

I just confirmed this, managed to download TappyChicken from my google play alpha deployement and it works with a 5 digit version number.

Ok cool. I’m going to mark your answer as the good one, and close this out as resolved for this issue. If you see anything else funky we can re-open this or start a new AH thread. Thanks very much!

For anyone else who has this problem I am going to go ahead and affirm that I spoke to the Android dev, and he confirmed that it is in fact that Google has made (undocumented) changes in how the obb is named and the leading zeros are the problem. He has made changes to the pushed directory for obb files so that they match the new expected locations. This change should go into effect with 4.8, possibly earlier if we have another 4.7 hotfix. Thanks much for your help, BaderThanBad!

when publishing on Android I have same error “Failed to open descriptor…”
My app-game is based on Tappy Chicken. I understood where you found the problem about the…obb file, but I didn’t see the way to do anything about it while publishing again.

While waiting for the fixed UE4.7.4 or 4.8 what can I do now? Google play developer site never mentions anything about .obb. Or am I wrong? I must be missing something.

Thank you in advance.

In the options for android inside the project you are going to have to chose a 5 digit version until this is fixed, something like 10001.

Ok, I finally understood how to do it, thank you BaderThanBad! You are Gooder Than Good! My updates are pending, and I hope this time my game will work in the Google play store in Androids…

Unfortunately, even if with this change, 10001 version, I have same message Failed to open descriptor… Maybe my problem is in something else?

I’ve changing my store version to 10002 (because my first was 00001) in UE 4.7.6 and it is working fine for me on Google Play (10001 should work too) :
THX BaderThanBad !

You sir, are a genius. Was going mad trying to figure out what was causing this issue.

same things with windows packaging on 4.8.2 and 4.7.6 ! a lot of bugs since 4.7.6 !!!