Download

Google achievements not being cached.

I am trying to test an achievement on my phone.
I have googled but not found a solution or way to solve it.
Since i spend a day on it already i think its time to ask for help.

What i did is:

  • upload apk to google play.
  • enable play services and link it to google play and set all achievements and the same achievements i put in UE4.
  • I created a keystore with the command:
    keytool -genkey -v -keystore my.keystore -keyalg RSA -keysize 2048 -validity 10000 -alias mykeystore
    in the <app>/Build/Android dir and i put the password in the EU4 distibution signing config

I can play my game on my device
when i trigger the achievement i see on my screen that it failed to cache.
The Show External Login UI does show some activity on my device (rotating circle) but fails.
When i open my device to see the logs i can not find any because i don’t know how.

My settings:

This is my test setup.

I hope someone can help me because it needs to be finished.

I uploaded my apk and my obb to google play and i enabled beta test for it.
I added myself as a tester.
Then i downloaded the apk and installed it on my phone with:

adb install 2-1.apk

Then on my phone i run it and i get the message on the image. It says: Download failed because the resource could not be found.

I the google play console i did add myself as a tester.

To test if something else does work i enabled the in game purchase, i run the app on my phone with ue4.
When i trigger the purchase i get this error. In english: Error with retreiving information from the server [DF-AA-20]
I am sure i used the correct id for the purchase.

Right now i am completely confused.
My phone is connected to my google account, my email is added as a tester. Internet on my phone works. What am i doing wrong.?