Download

Goodsky

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-tempid”:“temp_137393_1525855699722_434”}[/ATTACH]

GOOD SKY v2.3 (Updated March 22,2019) [HR][/HR]Permanently Free Content from March 1st, 2019

https://www.youtube.com/watch?v=hkmAao1g-1o

Purpose:

  • Quick and easy sky effects for artist.

Features:

  • Day / Night / Star / Moon / Sun / Storm.
  • Over 20 Sky Preset.
  • 4 Mode clouds style.
  • 6 Mode clouds coverage rate.
  • Material base on opaque and unlit mode.
  • Time of Day system.
  • Random Weather System.
  • Support Attach Direction Light.
  • Supported VR / Mobile Platform.
  • Day / Night Cycle(v2.3 beta)

Gallery:

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_137391_1525855663876_807”}[/ATTACH]

Supported Development Platforms: Window / Mobile / VR

Supported Engine Version :**
4.22~4.24 is 2.32 version
4.18~4.22 is 2.3 old version.** [HR][/HR]Any questions or comments you may have, please feel free to ask or follow the email linked below!
:slight_smile:

Support Email: [EMAIL=“feeling94750@gmail.com”]feeling94750@gmail.com [HR][/HR]
More Information : Marketplace page

I’m trying to make some lights turn on automatically at night and haven’t had any luck. The solution we come up with should probably work with any light really. Lamps, Porch Lights, Car Lights, etc…Anyone else? I’m attempting to use the get current time of day from the good sky bp.

I’ve adjusted everything. This is the current node structure. Still nothing happens when it turns night. The spot lights on my actor are set as visibility off as default. This should be turning them on based on the arrow tool rotation? Help guys!!

Hi guys!
I’m getting this warning in the console: “BP_GoodSky_2 Large actor receives a pre-shadow and will cause an extreme performance hit unless bCastDynamicShadow is set to false.”
How to solve it?
Thanks!

Hey there,

I’m trying to use the BP_GoodSky for the first time in a project made in Unreal Engine 4 version 4.22.3 however I’m getting some weird artifacts. I’ve attached a screenshot that shows what’s happening, basically there’s a bunch of white shapes.

I’ve gone through the documentation at https://drive.google.com/file/d/1mInnspix6tHFGq3-e7gKN5zn-uM3Ny7F/view but it doesn’t mention anything about this. I’m using version 2.0 of GoodSky in my project. Any help is greatly appreciated if anyone else has run into this issue!

I’m in UE4, and I placed the BP onto the sky, adjusted it to 0,0,0, and it does this, i’ve looked through the documentation and i cant find anything.

after rendering in the sequencer, such a panel appears at the output, tell me how to remove it?