Download

GolfBall Physics Collision Problem

Hi !

I’m currently creating a golf game and I have a question . My ball ( Sphere who simulates gravity with a linear and Angular damping) seems to collide with another floor. I mean, if a duplicate a floor at the same Z translate , when my ball moves from the first floor to the second , sometimes my ball collides with the edge of the second floor ( i think ) and its impulse . Anyone know why ?

https://youtu.be/j71vXrs6zew

the Z is not exactly the same?
The collision for the floors are different?

check the static mesh first, make sure both meshes are identical with the same collision Simple collision, because if you use complex it complicates things.
check the In Level mesh second, making sure the bounds are the same and the Z is exactly the same
Make sure the meshes aren’t gapped or overlapped they need to be adjacent to perfection too.
That’s the easy stuff to check.

Thank you for your answer MostHost LA

Planes are exactly at the same Z position ( both 572).
for prototyping , I use TemplateFloor given by UE4. I switched Project Default collision to use Simple collision as complex.
On the level i’ve duplicated the first TemplateFloor to get the second. SM are exactly the same and they aren’t overlapped or gapped. They are perfectly adjacent.

Double check the x/y/z numbers and maybe even force a full decimal point for precision.
whatever I have gap issues I add a fibonacci sequence past the . 113581321
it should truncate automatically. Just copy the truncated value and paste it on the other component.

I would suggest replacing the mesh with one you control the simple collision of to make sure that the collision too is perfect. Usually I use a cube for collision. It’s important to control the size of it exactly. You could potentially use convex and shrink the edges if you are still getting bouncing issues.

Z numbers are excatly the same ( Z = 572 )

the problem is the same with others Mesh ( Unreal’s Mesh and Maya’s Mesh ) I used geometry mesh and cube , plane , …

I’m not the only one person with this collision problem ( https://www.reddit.com/r/unrealengine/comments/7a52rc/helpweird_collision_on_a_ball/ )

In project settings under physics enable substepping, set max substep delta time to 0.002 and max substeps to 16, don’t know what anything of this does but it works in my case

EDIT: seems like it makes it better but doesn’t fix completely
EDIT 2: Set also min and max contact offset to 0.01