Going back to 4.15.1 on MAC?

After last update 4.15.2 Metal v1.2 stop working… I’m unable to open project on Metal v1.2. Opening unreal engine stops at 35% and nothing happens. On Metal v1.1 everything is ok, but tessellation won’t work.

So how can i go back to version 4.15.1 in witch everything worked fine?

Hey KRUChY-

If you are using the engine from the launcher, once the launcher has updated to a hotfix it cannot be reverted to a previous hotfix. You can visit GitHub (Epic Games · GitHub) to download the specific engine version/hotfix needed however. Once you have created a github account and linked it to your Epic Games account, you can click the Branch dropdown and switch to the Tags, category. Here you can download the specifc hotfix you want to use. Once you’ve downloaded this you will need to run Setup.command and GenerateProjectFiles.command to build the engine and switch your project’s engine association to your source engine.

Cheers

Doug Wilson

Hello, I’m also trying to roll back to 4.15.1 so that the Fabric Engine plugin will work (for working with Rhino files in Unreal). However I’m using Github on a PC and don’t see the option to view tags under Branches. Only 4.15 is on there, and I’m assuming if I install that, it will be 4.15.3 which isn’t compatible with the plugin.

Hey czechokeflavik-

If you are looking at the Branches tab then yes, downloading the 4.15 branch will download 4.15.3 hotfix.

Once you click on the Branch button (next to New pull request) there should be two tabs in the dropdown menu, one for Branches and one for Tags. Clicking on the Tags tab will allow you to download the individual hotfixes for each version. Can you post a screenshot of your dropdown menu?

Thanks for your reply Doug! I think I’m looking in the right place, but I don’t see the two tabs. I’ve attached a screenshot of my branch menu

I didn’t realize you were using the Git client. You can get a specific tag by opening the Git Shell and running the command git checkout [TagName] (in this case git checkout 4.15.1-release). Once the checkout completes you can then build the engine as normal. The directions I was using above assume going to the github.com website and downloading the build there as a .zip file.

Great, thanks for the clarification, I was able to download the source from the Github website.

Now I have a separate issue related to the setup. When running setup.bat, I’m getting the following error (attached).

190740-ue4151install.jpeg

It appears that the full path of one of the files it’s trying to create is too long. If you are running this from a nested folder, try building from a folder that is closer to the directory root. Also, if you’re on Mac you’ll want to run Setup.command rather than Setup.bat.

Thanks that worked! Can you advise on the next step though? How can I run 4.15.1 through the Epic Games Launcher? Currently I have 4.15.3 installed, and that’s all I see in the Library. (Sorry to be asking such basic questions, I’m very new to this).

An engine built from source cannot be added to the Launcher. The best option would be to add a shortcut to UE4Editor.exe to your desktop.

I’m stuck again, I’m probably out of my depth here. I’ve downloaded the repository, run setup.bat (I’m on a PC) and run GenerateProjectFiles.bat. I found UE4Laucher.exe on the system, but it started up 4.15.3. I have since removed 4.15.3 from the Launcher, but I don’t know how to proceed. Is the problem that I still need to “build” the engine from the source after downloading it?

Hey czechokeflavik-

Yes, after running Setup and GenerateProjectFiles, you need to open the UE4.sln (created after running GenerateProjectFiles) and build that solution. After building the solution you can find UE4Editor.exe in the Engine/Binaries/Win64 folder.

That worked, thanks again for all the help.