glowing materials not working on mobile?

i never tested out this, but i’m working on a bullet material right now, and the emissive color is not glowing at all, is just a plain color on a surface, and i opened another project, did the same test and it did work

Did you enable Mobile HDR in Rendering project settings?

activated and still not working

Did you turn on bloom in Rendering default project settings?

activated now, it works, thanks

But remember it requires much more powerful devices. You can simulate this effect with particle (for optimization).

well that is my concern, i really don’t get how bloom is something not supported by the majority of devices, it shouldn’t even be a feature for hdr on mobile, i’ll try to simulate that effect with particles, but i don’t know how will be the result tho