Global shader cache-pcd3d-sm5 missing

Hi, I don’t really know if I should post this here but I’m doing my first project in Unreal 4 and the last couple days I have been trying to package it for Windows. And this error kept poping up:


Then it just crashes your game before it even starts!

I couldn’t for the life of me find an answer. I’m an architect not a programer or game dev so all of the terms and logic are pretty new to me. But I finally figured it out and I just wanted to share with the community my discovery (I have been leeching on it since I began and it has helped quite a lot). Sorry for the long read btw.

The thing that was causing this error was found in my project name. UE4 doesn’t let you have projects with names that have spaces but if you (as I did) change your project name later in your file explorer you can change your name to one with spaces and UE4 won’t mind (Except for editing the .ini file to get your levels to run correctly) and you can keep building all without mayor issue. BUT when you package it you will get this message when trying to play your game.

So i just created a new proyect with the name I wanted without any spaces (using _ instead of space); deleting everything except the .uproject file in the new project folder, and then copied every single folder in my other proyect to the new one. This solved my problem. It may have worked by just changing my project name directly (too late to know now heh). So just check your files starting with your project name all the way to your textures don’t leave any names with spaces.

Hope this is helpful.


Thanks for sharing! Seems like just renaming the project works aswell :slight_smile:

Glad it was helpful! :smiley: And good to know it works by just changing the project name less of a hassle lol

solved topic!

thanks , thank very much. me too did change of my project name too later in my file explorer.