Glitches in .aab file after testing it on my mobile! No save game created!

APK is no longer supported on Google Play, So when I tested the .AAB file on my mobile the game becomes glitchy ! Especially “Save Game”. No Save Game created when using the aab or the universal apk, but apk arm64 works perfectly!

for example, my game has levels and all of them are locked except the first level, when I package it and install the arm64 on my mobile device everything is okay… But when I Upload the .AAB file for internal testing on Google Play and install it on my device it has a lot of glitches and I believe all of the exist because of the Save Game problem.

Also on arm64 I notice that in my files on mobile there is a folder with the name of the game inside the folder named “Ue4Game”. It contains the Save Game.
But the .AAB version does not create a folder with the game’s name at all !

I think it’s the last setting in the image that had to be checked. It worked now.
The setting is under Android → APK Packaging.

347451-untitled.png

May I ask what your target api level is?

The tartget is 30

When I target level 30 save file doesn’t get created whether ExternalFilesDir is checked or not because of read/write permissions. Did you do something specific to get it to save? I’m working locally with a development build, not uploading to Google, although I do not think it would make any difference.

I tried to change a bunch of settings together so I am not sure what made it work actually, but I will take screenshots for my settings:

When I was targetting api 30 I was. I had to switch to 29 to workaround this and continue developing. Api 29 has no problems with saving/loading whether it’s abb or not.
Thank you for the settings, I’ll try them.

Previous comments disappeared. Yes, I had the saving problem, I had to target api 29 to be able to save and continue developing. Now that I applied your settings and set up a Google developer account and did a signed build, my game works/saves as intended. I don’t know if it was the settings or the signing process but, thank you very much in any case.

I don’t think it’s because you were not signed. It happened with me even when I was signed.
You’re welcome :slight_smile:

And btw, Google Play did not accept a target api less than 30 when I uploaded it.