Gizmo disappears after playback

This is getting old and I assumed it would be fixed in UE5, maybe there is a better way to use Unreal and Sequencer?

When playing a sequence, say, I am animating the camera. During playback, the camera gizmo disappears, which is helpful for preview purposes. When playback stops, the gizmo is still hidden.

Clicking the camera does not show the gizmo. Instead, I need to click some other object and then click the camera again.

I am working in game mode because I need to see what the end result is, without things like sprites, etc. Also, because there are several objects set to be ‘hidden in game’ in sequencer.

Is anyone else experiencing this ongoing issue? Having to deselect and reselect and object constantly while animating? This happens 1000’s of times daily as I work.

2 Likes

I think you’ll find that’s just game mode, actually.

When you switch to GM, nothing is selected. Then you can select objects. I’m assuming the editor sets back to game mode after playing the sequence, hence no gizmos.

2 Likes

Yeah, that’s the problem.

Game mode doesn’t hide the gizmo when something is selected, but hides it after it is reset.

So, either game mode has to be toggled - which doesn’t work unless you click the Viewport options or bring focus to the viewport and tap “G” - Or, and object has to be deselected and reselected.

When working on a level sequence, it is very common to have a lot loaded but much of it hidden for a particular shot. We only need to see things specific to the shot - so, using, “Hidden in Game” we can use a level full of assets and only include what we need for the shot.

Now, without Game mode, everything including Sprites and the Camera(s) are visible in the shot when animating, which is a problem. When animating, we need to be focused on only what is in the shot, so we use Game Mode.

Now, using Game Mode means that the Gizmo is constantly disappearing. If I am animating, tweaking keys, toggling playback and tweaking again - now I must constantly unselect and reselect the thing I am animating, 100’s or 1000’s of times a day.

Is there a way to exclude the Gizmo from Game Mode’s view, so that it is always visible? Or better yet, restore visibility after playback?

2 Likes

The only thing that comes to mind is using a widget blueprint to play the sequencer ( it could just be a small box off to one side ). All it does it play the sequence, and then re-select the camera.

Maybe ?

2 Likes

Nice thinking! I could see how that would work. But no way could I just start abstracting the sequencer functionality, there’s just too much else that I use it for.

Does everyone else just deal with this? ClockworkOcean, are you noticing this behavior on your end?

2 Likes

You can work in exactly the same way, you just need to press a widget button instead of pressing play in the sequencer. ( I think, but am not sure ).

Do you use the sequencer in edit mode or play?

I did tinker with the sequencer a lot at one point. Much easier than rigging a mesh. But was very turned off by stuff like it’s inability to relocate the animation in the world.

At the time, it was supposed to work, but it didn’t.

UPDATE: I’ve had a rummage around and can’t find anything helpful. It might be possible to make an editor widget that selects the same actor again after the sequencer has run, but I can’t find enough info…

2 Likes

Thanks for looking into it and your thoughtful feedback. Feature request!

Yes, sorry I don’t have anything more definite. It might be possible with scripts, and defintely with C++.

Try toggling off Game View in the Sequencer toolbar. When that is enabled, Sequencer will turn on game view and hide viewport buttons while playing.

2 Likes

Amazing. That is exactly what I was looking for. Now I can playback my animations without deselecting and reselecting 1000’s of times a day.

Thank You

1 Like