Github plugin difficulty

I’ve just discovered the fantastic use of the newer GitHub plugin by SRombauts, and I set up a repo in Git and a barebones UE4 project in 4.18 with the plugin initialised, then I go ahead an initialise the project as an LFS project and it’s fine up to that point. My username and email and project location is fine and it IS using Git LFS 2. I press “Accept Settings”, then I go ahead and “Submit to Source Control” and it’s still okay. Then when I try push it says “Pushing local commits to remote origin…”, then I get Error push operation failed". I don’t know what’s making it fail, I initialised it properly and the settings were accepted fine, and my repo is set up properly. If I do Sync it fails as well and reloads everything in the project, and if I do Refresh it immediately says “UpdateStatus operation successful”.

Can anyone help me? I’d love to get this working but it’s not treating me nice. Maybe it is my repo set up wrong but as far as I’m concerned I don’t think it is…

Hi @SRombauts, love your work and appreciate the dedication!

  1. I set up an empty repo in Git, not the latter.
  2. No, I haven’t tried that yet but I’ll give it a go.
  3. Yeah I’ll look in a second and post back.

I think it is a Git LFS problem, how would I solve that? I’m not very skilled with Git.

Hi @masterworm2, can you give me a few more info please?

  1. When you say you set up a repo in Git, do you mean an empty repository on Github ? Or is it a local repository, correctly set-up to track a remote respository on Github (I believe the second one)?
  2. Are you able to push from your local repository from the command line git? Because the plugin is using the command line to commit/status/push/pull… to it needs to have correct authorization and so on.
  3. Can you look at the logs to see what is going wrong more precisely? See Saved/Logs/ in your project directory.

Also, it seems to me it is a Git remote or Git LFS problem, so it might be better to talk about this in my Github issues since those features are not yet merged in UnrealEngine

@SRombauts, my friend and I can’t figure this out, would it be possible to get your Discord and get help? It’s probably something small but it’s greatly appreciated if you can help. We tried to do git lfs push origin master from the command line but we keep getting Git LFS is disabled for this repository, and when we try to do git lfs install then try again nothing changes. I looked at the logs also and couldn’t really figure it out.

No, to be honest I am very busy at the moment, but I can give you an advice ;

  1. try to create an empty free test repository on Github
  2. Create an empty BP project, and Initialize local repository through the plugin’s connect screen : select LFS, and type in the URL of your Github remote repository, then click “Initialize…”
  3. This should create a Git repository, create the initial commit with Git LFS configuration, and push it automatically to Github

If this works then you can do the same with your own project. Else send me your logs

Sure thing, I keep getting this error though no matter what I try, in bash or in desktop, and in UE4 it simply fails, I’ll try an empty project now though!

alt text