GitHub linking isn't working

Hey guys,

I have tried everything and cannot seem to get GitHub to let me get to the Source repository. I get the same message others have gotten:

This organization has no public repositories.

I do have an active account, I did pay the $19, I entered my github username in proper case and it keeps putting it to lower on my account page so I even attempted to change my github username to all lower, clear my username, and re-enter it. I created a new github and tried that, I created a basic repository on my page to see if any activity would trigger it, changed my github username on my account back to my real github, logged in and out of both sites, and used all browsers repeating the steps.

Went through the videos and the tutorials on the site.

It just isn’t linking them.

Anyone have any ideas? Is it not an instant thing after I purchase?

Hey ,

So, let me just make sure we’re on the same page here.

I followed this tutorial to get GitHub set up myself: A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums

You did the relevant steps, including updating your Unreal account to add your GitHub account.

And when you got to this step:


You don’t see anything under Epic Games - or rather, it says ‘This organization has no public repositories.’

Is that correct?

That is correct. I just did it again and have the same results. Nothing.
I tried quite a few times and got the same result even with another github account I created fresh for this purpose.

I just tried to clear it out, save, log out of both, log in to my unreal account, set it, then log into github. There is no organizations section.

Did you ever get an email confirming that you’d connected your Unreal account with your GitHub account?

I was earlier but when I just changed it I did not. It doesn’t appear to be sending anything to me at the moment. This was one of the emails from earlier:

Hi Nicholas,

You have successfully added a github association to your account. If you did not make this request, please contact us immediately.

ok it just now came through in my email. It says I have successfully added my github association but it did not work. I still don’t have any organizations listed.

You should be getting a second email after the first one. The second email should say something like [GitHub] ______ has invited you to join the Epic Games organization. If you didn’t get that email (even in your Spam folder), then it means there’s a problem we need to investigate further.

I have only gotten the email that said I added or removed a github association. I haven’t gotten anything from github or from epic concerning an invitation of any sort.

Gotcha. I’ll keep looking into it.

Thank you.

Hey -

There is something else I’d like you to check when you have the chance. Go to this link: Epic Games · GitHub and check if you see a green button near the top right saying “Join”?

Although I don’t have anything to add onto this, I’ll just throw my name into the hat. I’ve also followed the Wiki setup steps and I’m not getting an invite either. I gave it a night (figuring it may be manual,) but I woke up today and still no dice.
Just like , I got the email from Epic confirming I had linked my account, but no email from GitHub. I get the same “This Organization has no public repositories.” and there’s no join button on the Epic Games GitHub page.

Alright guys, thanks for the information. This issue has been escalated and we’ll figure it out ASAP.

Fixed for me. Thanks.

Yep, same. I got my GitHub invite about an hour ago.
Add another thanks from me. =P

Hey guys-

There was a problem with connecting Unreal and GitHub accounts yesterday and we have tracked the cause and implemented a fix. If anyone experiences this issue in the future please start a new post and we will investigate.