Download

Github for my project.

I am trying to use github for my project… and i have hte LFS working and all that… push in the command line of github works if i do certain folders or files seperately… but trying to do an initial commit of the entire project wont work… I attached a screenshot of that problem. it says “pack exceeds maximum allowed size” … any idea how to get around that?

Also inside the engine i am using github… and im curious about a few things…

1.) what does sync do in engine? In git hub it syncs whats been commited… but in unreal it doesnt seem to do anything at all… No bandwidth is used so its not uploading anything…

2.) How does the check in check out system work? If i check out a file will other people using this repository see it as checked out? Will they be un able to modify it until i check it back in? Do i have to sync everytime i check out and sync every time i check in ?

Been trying to do a work around and upload things seperately… slowly… but now i have a 450 or so mb file… and now i have an error for that… a different error… See attached screenshot…

That’s what it should do, but git doesn’t provide such a functionality since it is decentralised.
Other Versioning Systems like Subversion and Perforce support this.

The answer to this is right there in the picture. Github doesn’t support files larger than 100mb

I would suggest you only put your games source code into git, and use other means to archive assets. Git is not good at all with binary files, I think it doesn’t even attempt to save just differences. If you change a 500 MB asset it will add another 500 MB to your repository. For every single change again. Maybe even for a change in file attributes.

Put your content folder in a 7zip archive f.e., you could make a script that compresses it and tacks the current date to the archive filename; or the current git hash you are at.

BTW what do you mean with you can upload folders separatly? How do you push parts of an repo??

When i mean seperately i mean individual files… But in either case ive been working with the git hub people for about a week on this. Might have a solution today… We will see when i get back to my computer to test it.

@ ExCluSiv3

Git hub actually does support files larger then 100 mb with their LARGE FILE SYSTEM. Thats what were having trouble make work. Its becoming standard stuff for git to use LFS, but u have to request it and pay extra for it.

100 mb is the limit for traditional git hub stuff… and there in lies the problem. The file types are associated with the LFS and yet its still ******** up… With a brand new repository it doesnt even say 100mb limit any more it just says other stuff like this…

I don’t know if paid versions support larger files, but in the free version more than 100mb aren’t allowed.

Quote:

And your new error means your repo couldn’t be found (the message couldn’t be more straightforward)

It does and its very possible its working now… doing a final test. Apparently they are still so new with the LFS stuff… that they had it set for only 1 hour to accept the file… and if ur still uploading beyond and hour… it just stops looking for the file and gives up on u… They just set the repository to do 24 hours in stead for max upload time… so we will see how well this works out.

And another thing… dont start giving out answers like there facts when you really have no idea. Its not straightforward… because as i said… it found it just fine… but it wouldnt allow more then 1 hour for an upload… just like your straight forward remark when u say it dont allow more then 100mb when clearly LFS does.

I can’t remember i said that with lfs you can’t upload higher file sizes.
You never said that you actually requested and paid for lfs support, you only said that you HAVE TO do this if you want to use it.
Without this information no one can tell you more than what the errors say.

" when you really have no idea"

Sorry that i wanted to help you with minimal information you gave. And just to let you know, i host my own git server with lfs support, don’t pretend things you have no clue about.

But i’m glad you could resolve your problem

Um I beleive the first sentence in my post said I am using LFS and its set up… And if u use lfs then why even say git cant go 100mb when it can with lfs. And then argue about it… your so flip floppy its irritating… . Regaurdless problem solved and it works now.