Git Source Control Plugin: Submit to Source Control not working!

I tried the new UE4.12 binary release, converting one of my BP/C++ simple project using my Git Plugin

I got a bunch of errors when I pressed the “Submit to Source Control” button in Source Control menu:
SourceControl:Error: Error fatal: Not a git repository: ‘/Script/.git’ SourceControl:Error: Error fatal: Not a git repository: ‘/Script/.git’
ourceControl:Error: Error fatal: Not a git repository: ‘C:/Program Files (x86)/Epic Games/4.12/Engine/Content/.git’
EditorErrors:Warning: Warning Failed checking source control status!

I was very disappointed as I am the maintainer of this plugin, but I didn’t catch this bug during the few previews I tried.

Sadly, on my first try to reproduce it with a build from source, the error dit not appear, so for now I am not sure of the reason nor of the fix.

I already have a first user bug report here on Github
I am posting this in early state for other people to know that I will work on it during the weekend.

I’m having this problem as well. ever since 4.12 it gives me an error…

Any fix for this?

The problem is that absolute paths outside the Project Working Copy are considered as possible target for “migrate” scenario… which is simple nonsense for anything else then Source Control “add” Operation!

But I’ve never seen this error before because during development my whole Engine is itself in Git Source Control!

The Fix is to only consider “add” operation for “migrate” scenario. It is an easy one-liner obvious fix with no regression of any sort!

=> I submitted on Github the fix as a Pull Request Git Plugin: fix the Submit To Source Control menu broken by new “migrate” support in 4.12 (and master) #2484


Good news, my fix has been merged a few minutes ago on upcoming 4.12.3 :slight_smile:

Glad to hear that this will be fixed soon. I’m waiting on it myself.

I can confirm that the plugin is working now in the 4.12.3 release.

Thank you :slight_smile:

It’s obviously not working anymore on 4.13.2 :confused:

Sorry to hear that you are having problems with the Git plugin @Executum.

Can you tell us what is wrong with your project? I am using 4.13.2 with no problem.
I just tried a Third Person Blueprint project as a fresh test, which worked flawlessly. I assume you are doing something more complex thant that:

  1. I assume you are using the UE4.13.2 binary release without source modification. But are you using other plugins?
  2. Is this a Content/BP only project, or with C++?
  3. What is the scenario of your problem?
  4. Can you see it on a fresh simple project, or only with your project?
    Please let me know.

Hi ! I managed to solve the problem.
So :

  1. Yes, I use 4.13.2 binary release downloaded from Epic launcher without modified nor downloaded sources. I didn’t disabled any of built-in plugins, and i installed “Low Entry Extended Standard Library”, “VaRest”, “Substance”.

  2. It’s a Content/BP only sample project/

  3. Scenario : I added git source control and had a message log saying it worked. Check out modified files wasn’t clickable, i tried submitting to source control but didn’t work with the error noted on this thread.

I solved the problem without knowing how. The only thing i did meanwhile was committing manually with “git bash” a first time and pushed the repository and also restarting the project that i didn’t close since creation.

This is odd, I am not able to get something like this, whatever the way I initialize the git repository…

Also, when you add Git Source Control to an existing project you can ask the plugin to “Make the first commit” with whatever commit message you want (default is “Initial commit”).