Gigantic socket problem, blender

I imported the free soldier mesh from mixamo Soldier Character Pack | 3D Humanoids | Unity Asset Store in blender to animate it as per my need and then when I export it I set the scale to 100 so it is of proper size in UE4.

However this causes any sockets I add to become 100 times larger as well, In other words it looks as follows:

Here the that giant wireframe is the socket attached to the head bone. Even though I have set the relative scale to 0.01 to compensate it wont work on the socket size itself.

Please Help me out here

EDIT: This only happens for meshes which I import from somewhere else into blender and then edit and export. In case I make the whole skeleton in blender its fine in terms of scale

Sounds like your problem may be importing into blender. Are your settings set for cm or inches/etc for importing?

Maybe try applying scale in blender? Select everything, ctrl + a

I’ve found the metrics or units “solutions” doesn’t help with anything, it just changes the visual scale in Unreal, and is even overridden if you change export or import scale.
I have this problem too and have found no answers. Mesh and skeleton looks fine in the editor but sockets are 100x too big.
But I have this problem even with custom made Blender assets…

Typically this giant socket/bone problem is due to using the import scale in the SkeletalMesh import properties. It alters the scale of the mesh but does not affect the transforms on the skeleton itself.

Your best bet is to remove all scale values from your model and skeleton then import that version with no import scale into unreal.