Getting Out of 'Set Input Mode UI Only' using a Gamepad?

Hey Guys,

I’ve built an inventory/crafting screen that is enabled when the player presses the ‘select’ key on the gamepad. For several reasons, I’m not using a Game Pause node, so it seems my only option to control just the inventory screen is to use the Set Input Mode UI Only and Set Input Mode Game Only nodes. The problem, however, is that once you’re in UI only mode, all of your keypresses are ignored and the only way I can figure out how to exit the UI only mode is through a button in UMG which is clicked with the mouse (after an 'Enable Mouse Cursor node). Is there any way to do this without a mouse?


I’d recommend checking out this thread. I was pointed in this direction for the same thing (except keyboard input not gamepad), but you should be able to do the same methods and check for gamepad inputs instead of keyboard inputs.

This took me hours but I found a better solution to get out of Set Input Mode UI Only with a key press. You have to select the Canvas Panel (or whatever your root node is) and set Visibility to Visible. Also, make sure your widget is set to focusable (not included in the picture but can be done with the SetIsFocusable node). Then in the OnKeyDown event close your widget.