Getting no error message but can't compile "Dirty; needs to recompiled"

I’m trying to compile in the Event graph in my ThirdPersonCharacter BP…

When hover compile button i’m getting “Dirty; needs to recompiled”

Did try save all to no effect… now all my widgets are not displaying :frowning:

Using version 4.14.3

Need Help please!!

Hello Khol76,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any settings/blueprints/widgets that may be involved with this issue?
  4. Could you search through your project and an insure that you do not have any circular dependencies?

Was following this tutorial: [Eng] Slot-based Inventory System: Adding the Hotkeybar #031 - YouTube
Was not able to reproduce the issue. Tried the newer version of the engine (15) and did a copy, same result…

Could you provide a zipped down copy of the project that does reproduce this issue?

Hello Khol76,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.