Download

Getting Hairworks to work makes me want to pull out my hair!

SERIOUSLY. Why does God hate me? All I want to do is get this thing to work and I’ve tried EVERYTHING.

Running on a brand new Dell computer with Windows 8 with Direct X 11, 16GB Ram and a Geforce GTX 745.

  • Hairworks 1.1 viewer and 3ds Max 2016 plugin downloaded, installed and running.
  • Engine Source Files downloaded from Github & built using Visual Studio 2015. (does it HAVE to be 2013?)
  • Installed latest version of Unreal Engine 4.9.1.

After building, I ran UE Editor and opened the demo file for hair works, but none of the hair shows up.
When I try to load my own .apx hair files, I get the “FAILED TO LOAD ASSETS”. Specifically, it’s telling me
that the “LOCALIZATION SERVICE IS DISABLED” and “SOURCE CONTROL IS DISABLED” x 5.

What am I missing? In the following step by step setup instructions by Epic, I completely don’t understand
what they are asking in the first few steps. Is this a necessary step? If so, why isn’t it covered in any
other tutorial? This is all very confusing and it seems like they’ve gone out of their way to make this
as difficult as possible.

Welcome to the HairWorks branch of the NvPhysX fork of Unreal Engine source code!

HairWorks implements physical hair simulation using DirectX Compute.

To build the HairWorks branch, using a git shell:

git clone https://github.com/NvPhysX/UnrealEngine.git

{wait until it’s done}

cd UnrealEngine

git branch -t HairWorks origin/HairWorks

git checkout HairWorks

.\Setup.bat

.\GenerateProjectFiles.bat

.\UE4.sln

{Build UnrealEngine solution}

{Run the editor.}

Editor Usage:

By not making this plugin installation more user friendly (or at least offering a decent video tutorial) it seems to me that Epic is leaving artists and designers out of the development loop. You know… people who could actually use the **** thing.

That’s not up to Epic, Nvidia controls the GameWorks stuff. I think you do have to use version 2013
I’m not sure though whether Hairworks is ready for use yet though, you’ll have to check out the gameworks thread: https://forums.unrealengine.com/showthread.php?53735-NVIDIA-GameWorks-Integration

Not ready for use? I’ve watched videos where people are using it and able to import hair files.

The HairWorks branch is still under heavily development, this is what is meant by “Not ready for use”. Of course you can use it, but as you have learnt, installation can be quite tricky, and you may run into limitations or other issues. Eventually once the GameWorks branch become more evolved, there is talk of attempting to convert them to plugins (although no easy task, nor should this be expected any time soon).

Also as darthviper pointed out, Visual Studio 2013 must be used.

I just tried again, using Visual Studio 2013 and same results. How unfortunate… I was really looking forward to using this. Now I’ll probably move on and lose interest.

It really shouldn’t be THAT hard to get some **** hair moving around. Sounds more like politics to me… the big companies want to use these features first before they lose their novelty and anyone with a decent computer can do it.

Are you sure your using the right built engine version and the right HairWorks plugin? Because building the branch and using v1.1 of the HairWorks plugin works, I have been using the HairWorks branch since it was released without any issues. Using an older plugin or the wrong version of the engine will definitely result in the APX not being able to be imported. (Just a FYI, those other errors you get about localization and source control have nothing to do with HairWorks and can be safetly ignored).

It really isn’t that difficult nor has it got anything to do with politics.

I have done everything the instructions said to do. You are right, it’s not that difficult to do… but it’s still not working. That’s why I’m annoyed.

Thats why I am suspecting that you may be launching the wrong version of the engine, or your using an outdated HairWorks plugin. Otherwise the APX file should at least import.

And the typical “trail by error” technique is extremely difficult when it takes hours to build the engine every time in Visual Studio. When I say politics, I mean that the official support just isn’t there for this feature… and the only reason is because it doesn’t work on all platforms. It’s like when Apple decided it didn’t want to include Flash. It was only because they wanted to sell their own apps, and didn’t want to make it easy for everyone to create their own. They were literally like, we don’t need user friendly tools… everyone should just learn HTML5 and get with the future.

If you want, you can send me the APX file you have created and I can test if it can be imported into my version of the HairWorks branch.

Thanks, I will do that if I can’t get it working by tomorrow.

Here’s a quote from the guys at Epic:

“While this can be implemented(Hairworks), Epic will not be implementing it directly into the engine until there is a cross-platform solution. This may change in the future but is currently not planned.”

That doesn’t surprise me, however here is a quote from Alexey from NVIDIA:

So eventually the hope is that all NVIDIA techs will become plugins to UE4.

Where can I send you the APX file?

Sent you a PM

I have a similar problem. I try to import a hair asset (.apx) in this the following branch of the engine (4.7.4): https://github.com/NvPhysX/UnrealEngine.
I built it with Visual Studio 2013 (including MFC Libraries) and use the Hairworks SDK (Standalone) v. 1.1.

I try to import it, but it gives the error:

‘Failed to import … Failed to create asset …’

Any tips are greatly appreciated.

Did you make sure u actually used this branch of the above link: https://github.com/NvPhysX/UnrealEngine/tree/HairWorks as that is the only branch that will work with HairWorks. Otherwise you can try my branch, link is in my signature. (Make sure to be logged into Github with an account linked to your UE4 account or you will get a 404 error)

Hair works Problem

Thanks GalaxyMan2015! This build finally works. My new problem is that now my hair looks very transparent when I import it from Maya (in Maya it looks good). any Idea what can it be?
Before downloading your build I couldn’t even import the hair in so that`s some progress. Thank you again.