Getting geometry to stick to grid?

I’m really new in UE4 and watched trough the Tutorials and such but can’t figure out why I can’t get the objects to align to the same grid system.

As you can see in the image below I can never get the walls and such to align with each other. What am I doing wrong? I’m kinda pedantic and this drives me mad.

http://puu.sh/az6IC/ae2038b453.png

Hi MrQ,

Make sure that your BSP geometry is created in units that relate to your Drag Grid size. In the top right of the viewport you can set this to whatever increments you need. For instance you can set it to 10 and as long as your geometry is an increment of 10 it will snap together easily.

11614-ahub_snapping.jpg

I hope that helps, TJ

I would recommend you to:

  • use grid snapping (right upper corner you can disable/enable and change some values
  • edit bsp brushes in the 4 window view → click onto the little button at the right upper corner

By the image you have changed your Grid Setting to 1 quadrant. Try changing it to the standard 10, as fighter5347 says. you can change this by the setting of the grid image at the top right of the Viewport.

if you are finding it a pain now to get it right. go to one of the other perspectives. select the piece of Geometry, and then right click on one of the corners. this will align it back to the grid. (only do this once you have set the Grid snapping to the setting you want it at.)

look at my answer below. maybe that will help?

The thing is I’m doing an apartment atm and 10 = 10cm which is way to much for snapping atm :/. 1 works great but just that the objects never are on the same grid :(.

Grid snapping is on (the button beside the value right?)
The bsp brushes thing I honestly have no clue what it is. As I said I’m very new to UE4.

Went into top view and tried the right clicking corner thing. Although this seems to nothing except give me the X and Y arrows.

are you in Geometry Editing mode?

11625-blarg.png

Select place mode and then right click the corner. it will snap the geometry to the grid.

http://puu.sh/azcAu/71847e463b.png

In place mode and top view. As seen on the picture the wall in question is place ½cm of grid. Right clicks corner and all that happens is X and Y arrows appear.

Sadly no difference. Still ½cm off-grid. Zoomed in as much as possible :/.

ahh yeah the arrows should appear your right. are you zoomed all the way in to see the whole grid pattern. that works for me every time.

I don’t get why your arrows are slightly offset from the actual square also. :confused: mysterious.

this might be the reason why you are experiencing an issue with the alignment.

maybe you can try changing whether its Global or local selection. See next to the grid snap setting. there is a planet, click that. you should see a cube. try that and then try my method?

Im sorry to hear that. its a shame. I really don’t understand why. looks like you might just have to delete that bit of geometry and bring a fresh bit in, it should be snapped to the grid from the moment you get it in there.

Hmm, seems like I found the cause atleast. It only happens when the item in question has a scale of uneven number. For some reason it centers on the middle so if the wall is 7cm wide it centers it and therefore is 3,5cm to both sides = ½cm off-grid. At 8 though it’s 4 cm on both sides = on-grid.

So there comes the next question. Can you turn off auto centering somehow?

Yea, think that would drive me mad ^^. For now I’ll keep the lengths in even numbers :). Thanks for all the help though!

okay so i have recreated your same sized piece of Geometry, and tried. everything works. I don’t think there is a way of removing the centering. I can get my piece to snap just fine.

you could wing it. and turn of grid snap. and just get it as close as possible! :smiley:

I am really sorry that we couldn’t solve the problem. That is going to bug the hell out of me now! I hope you know that :stuck_out_tongue:

You’re welcome :slight_smile: