Download

Getting Error "Character.ArrowComponenet is not blueprint visible"

I’m following a youtube tutorial and in it he adds a component arrow to the blueprint but When compiling, i get a WARNING stating Character.arrowcomponenet is not blueprint visible, Please fix markup or cease accessing as this will be made an error in future release.

The warning does not pop up in video, only in my blueprint. How do I fix this?

I have the same error.
Trying to use the ArrowComponent for a projectile. Did you find a way to fix it?

I have the same error message trying to use ArrowComponent for a projectile. Did you find a way to fix it?

I am thinking this has something to do with the newer versions of unreal. I am also getting this, and notice that this question is quite old already.
But when I select the arrow component it has no info in the details panel.

It seems to run fine without any other errors popping up. But ive seen other people post that when building your project it can crash on you.
I would like to see an answer to this myself.

Hey guy and gals,

I found myself with the same problem but i have found a fix!

Simply add your own arrow component to the mesh and “Get” it instead on using the “ArrowComponent” attached to the Capsule. Then all you have to do is recomplie and the error should be gone!

As for why we are getting the error in the first place, i think it is because the exsisting “ArrowComponent” isn’t usable in blueprints anymore and is just to show which way the capsule is facing.

Hope this helps.

Thanks! Works perfect!