Download

Getting a Fatal Error when I try to run packaged game on laptop, but works fine on another comp

The laptop has visual studio 2015 and 2017 installed with common tools aswell. the Unreal Engine runs on the laptop and can play games in PIE but can not run builds that I make on my Main computer. This is the crash log for the laptop:


Log file open, 05/30/17 21:55:23
LogInit:Display: Running engine for game: MyProject
LogInit:Display: Project file not found: ../../../MyProject/MyProject.uproject
LogInit:Display: 	Attempting to find via project info helper.
LogUProjectInfo: Found projects:
LogPlatformFile: Not using cached read wrapper
LogInit:Display: RandInit(-476594899) SRandInit(-476594899).
LogTaskGraph: Started task graph with 5 named threads and 8 total threads with 1 sets of task threads.
LogStats: Stats thread started at 0.137883
LogInit: Using libcurl 7.47.1
LogInit:  - built for i386-pc-win32
LogInit:  - supports SSL with OpenSSL/1.0.2g
LogInit:  - supports HTTP deflate (compression) using libz 1.2.8
LogInit:  - other features:
LogInit:      CURL_VERSION_SSL
LogInit:      CURL_VERSION_LIBZ
LogInit:      CURL_VERSION_IPV6
LogInit:      CURL_VERSION_ASYNCHDNS
LogInit:      CURL_VERSION_LARGEFILE
LogInit:      CURL_VERSION_IDN
LogInit:  CurlRequestOptions (configurable via config and command line):
LogInit:  - bVerifyPeer = false  - Libcurl will NOT verify peer certificate
LogInit:  - bUseHttpProxy = false  - Libcurl will NOT use HTTP proxy
LogInit:  - bDontReuseConnections = false  - Libcurl will reuse connections
LogInit:  - CertBundlePath = nullptr  - Libcurl will use whatever was configured at build time.
LogInit: Build: ++UE4+Release-4.16-CL-3452394
LogInit: Engine Version: 4.16.0-3452394+++UE4+Release-4.16
LogInit: Compatible Engine Version: 4.16.0-3452394+++UE4+Release-4.16
LogInit: Net CL: 3452394
LogDevObjectVersion: Number of dev versions registered: 16
LogDevObjectVersion:   Dev-Blueprints (B0D832E4-1F89-4F0D-ACCF-7EB736FD4AA2): 9
LogDevObjectVersion:   Dev-Build (E1C64328-A22C-4D53-A36C-8E866417BD8C): 0
LogDevObjectVersion:   Dev-Core (375EC13C-06E4-48FB-B500-84F0262A717E): 2
LogDevObjectVersion:   Dev-Editor (E4B068ED-F494-42E9-A231-DA0B2E46BB41): 17
LogDevObjectVersion:   Dev-Framework (CFFC743F-43B0-4480-9391-14DF171D2073): 23
LogDevObjectVersion:   Dev-Mobile (B02B49B5-BB20-44E9-A304-32B752E40360): 0
LogDevObjectVersion:   Dev-Networking (A4E4105C-59A1-49B5-A7C5-40C4547EDFEE): 0
LogDevObjectVersion:   Dev-Online (39C831C9-5AE6-47DC-9A44-9C173E1C8E7C): 0
LogDevObjectVersion:   Dev-Physics (78F01B33-EBEA-4F98-B9B4-84EACCB95AA2): 0
LogDevObjectVersion:   Dev-Platform (6631380F-2D4D-43E0-8009-CF276956A95A): 0
LogDevObjectVersion:   Dev-Rendering (12F88B9F-8875-4AFC-A67C-D90C383ABD29): 15
LogDevObjectVersion:   Dev-Sequencer (7B5AE74C-D270-4C10-A958-57980B212A5A): 4
LogDevObjectVersion:   Dev-VR (D7296918-1DD6-4BDD-9DE2-64A83CC13884): 0
LogDevObjectVersion:   Dev-LoadTimes (C2A15278-BFE7-4AFE-6C17-90FF531DF755): 1
LogDevObjectVersion:   Private-Geometry (6EACA3D4-40EC-4CC1-B786-8BED09428FC5): 1
LogDevObjectVersion:   Dev-AnimPhys (29E575DD-E0A3-4627-9D10-D276232CDCEA): 3
LogInit: Compiled (32-bit): May 22 2017 17:58:27
LogInit: Compiled with Visual C++: 19.00.23026.00
LogInit: Build Configuration: Development
LogInit: Branch Name: ++UE4+Release-4.16
LogInit: Command line:  
LogInit: Base directory: C:/Users/kyle/Documents/Unreal BUILDS laptop/TestProj/WindowsNoEditor/Engine/Binaries/Win32/
LogInit: Installed Engine Build: 0
LogInit: Presizing for max 2097152 objects, including 0 objects not considered by GC, pre-allocating 0 bytes for permanent pool.
LogStreaming:Display: Async Loading initialized: Event Driven Loader: true, Async Loading Thread: false
LogInit: Object subsystem initialized
[2017.05.31-04.55.23:752]  0]LogInit: Selected Device Profile: [WindowsNoEditor]
[2017.05.31-04.55.23:752]  0]LogInit: Applying CVar settings loaded from the selected device profile: [WindowsNoEditor]
[2017.05.31-04.55.23:767]  0]LogInit: Computer: LAPTOP
[2017.05.31-04.55.23:767]  0]LogInit: User: KyleKeshiaLaptop
[2017.05.31-04.55.23:767]  0]LogInit: CPU Page size=4096, Cores=4
[2017.05.31-04.55.23:767]  0]LogInit: High frequency timer resolution =1.852009 MHz
[2017.05.31-04.55.23:768]  0]LogMemory: Memory total: Physical=3.5GB (0GB approx) Virtual=4.0GB
[2017.05.31-04.55.23:768]  0]LogMemory: Platform Memory Stats for WindowsNoEditor
[2017.05.31-04.55.23:768]  0]LogMemory: Process Physical Memory: 70.95 MB used, 70.95 MB peak
[2017.05.31-04.55.23:768]  0]LogMemory: Process Virtual Memory: 84.68 MB used, 84.68 MB peak
[2017.05.31-04.55.23:768]  0]LogMemory: Physical Memory: 1731.13 MB used,  1809.34 MB free, 3540.47 MB total
[2017.05.31-04.55.23:768]  0]LogMemory: Virtual Memory: 286.20 MB used,  1809.34 MB free, 4095.88 MB total
[2017.05.31-04.55.24:026]  0]LogInit: Using OS detected language (en-US).
[2017.05.31-04.55.24:026]  0]LogInit: Using OS detected locale (en-US).
[2017.05.31-04.55.24:027]  0]LogTextLocalizationManager: No specific localization for 'en-US' exists, so the 'en' localization will be used.
[2017.05.31-04.55.24:288]  0]LogD3D11RHI: D3D11 adapters:
[2017.05.31-04.55.24:320]  0]LogD3D11RHI:    0. 'AMD Radeon HD 7640G' (Feature Level 11_0)
[2017.05.31-04.55.24:320]  0]LogD3D11RHI:       497/0/1536 MB DedicatedVideo/DedicatedSystem/SharedSystem, Outputs:1, VendorId:0x1002
[2017.05.31-04.55.24:329]  0]LogD3D11RHI:    1. 'Microsoft Basic Render Driver' (Feature Level 11_0)
[2017.05.31-04.55.24:329]  0]LogD3D11RHI:       0/0/1770 MB DedicatedVideo/DedicatedSystem/SharedSystem, Outputs:0, VendorId:0x1414
[2017.05.31-04.55.24:329]  0]LogD3D11RHI: Chosen D3D11 Adapter: 0
[2017.05.31-04.55.24:349]  0]LogD3D11RHI: Creating new Direct3DDevice
[2017.05.31-04.55.24:349]  0]LogD3D11RHI:     GPU DeviceId: 0x9903 (for the marketing name, search the web for "GPU Device Id")
[2017.05.31-04.55.24:349]  0]LogWindows: EnumDisplayDevices:
[2017.05.31-04.55.24:349]  0]LogWindows:    0. 'AMD Radeon HD 7640G' (P:1 D:1)
[2017.05.31-04.55.24:350]  0]LogWindows:    1. 'AMD Radeon HD 7640G' (P:0 D:0)
[2017.05.31-04.55.24:351]  0]LogWindows:    2. 'AMD Radeon HD 7640G' (P:0 D:0)
[2017.05.31-04.55.24:352]  0]LogWindows:    3. 'AMD Radeon HD 7640G' (P:0 D:0)
[2017.05.31-04.55.24:353]  0]LogWindows: DebugString: FoundDriverCount:4 
[2017.05.31-04.55.24:353]  0]LogD3D11RHI:     Adapter Name: AMD Radeon HD 7640G
[2017.05.31-04.55.24:353]  0]LogD3D11RHI:   Driver Version: 15.201.1151.1008 (internal:15.201.1151.1008, unified:15.201.1151.1008)
[2017.05.31-04.55.24:353]  0]LogD3D11RHI:      Driver Date: 11-4-2015
[2017.05.31-04.55.24:353]  0]LogRHI: Texture pool is 348 MB (70% of 497 MB)
[2017.05.31-04.55.24:411]  0]LogD3D11RHI: AMD Pre GCN architecture detected, some driver workarounds will be in place
[2017.05.31-04.55.24:443]  0]LogD3D11RHI: Async texture creation enabled
[2017.05.31-04.55.24:492]  0]LogD3D11RHI: GPU Timing Frequency: 50.000000 (Debug: 2 1)
[2017.05.31-04.56.24:494]  0]LogWindows:Warning: CreateProc failed (2) ../../../Engine/Binaries/Win32/CrashReportClient.exe "C:/Users/kyle/Documents/Unreal BUILDS laptop/TestProj/WindowsNoEditor/MyProject/Saved/Crashes/UE4CC-Windows-1804CF614444C8B900EA31828EC65A06_0000" -AppName=UE4-MyProject -CrashGUID=UE4CC-Windows-1804CF614444C8B900EA31828EC65A06_0000 -DebugSymbols=..\..\..\Engine\Intermediate\Symbols
[2017.05.31-04.56.24:494]  0]LogWindows: Could not start CrashReportClient.exe
[2017.05.31-04.56.24:494]  0]LogMemory: Platform Memory Stats for WindowsNoEditor
[2017.05.31-04.56.24:494]  0]LogMemory: Process Physical Memory: 102.20 MB used, 102.46 MB peak
[2017.05.31-04.56.24:494]  0]LogMemory: Process Virtual Memory: 109.49 MB used, 110.08 MB peak
[2017.05.31-04.56.24:494]  0]LogMemory: Physical Memory: 1849.39 MB used,  1691.08 MB free, 3540.47 MB total
[2017.05.31-04.56.24:494]  0]LogMemory: Virtual Memory: 390.37 MB used,  1691.08 MB free, 4095.88 MB total
[2017.05.31-04.56.24:494]  0]LogWindows:Error: === Critical error: ===
[2017.05.31-04.56.24:494]  0]LogWindows:Error: 
[2017.05.31-04.56.24:494]  0]LogWindows:Error: Fatal error!
[2017.05.31-04.56.24:494]  0]LogWindows:Error: 
[2017.05.31-04.56.24:494]  0]LogWindows:Error: 
[2017.05.31-04.56.24:516]  0]LogExit: Executing StaticShutdownAfterError
[2017.05.31-04.56.24:517]  0]LogWindows: FPlatformMisc::RequestExit(1)
[2017.05.31-04.56.24:517]  0]Log file closed, 05/30/17 21:56:24


I dont get any error codes or info with the Fatal Error crash dialog.

Any help is appreciated!

Looks like you ran out of memory, you only have 4GB

Thanks for pointing that out!

For what its worth, the issue was an outdated graphics driver. Downloaded the latests drivers and everything is working fine. Rookie mistake!

How did you get that log file? I was trying to use windows event viewer but it isn’t giving me anything useful. It’s not even showing me the latest crash. I’ve tried updating to the latest driver but still no joy. How is that error even useful?!