Download

GetHitResultUnderCursor doesn't work under Gentoo Linux

This is kind of an odd issue, but when trying to use GetHitResultUnderCursor, GetMousePosition, etc. they all return zero’s.

This issue also happens in the “Top Down” example project where the green circle that’s suppose to follow the mouse is not visible, and clicking doesn’t make the character move at all.

I should note that making the mouse use touch controls allows me to move the character properly in the “Top Down” example project.

I tried running “Top Down” under Xfce since I thought the tiling window manager I use wasn’t cooperating, but that didn’t work. I also tried using a clean Xorg config (moving everything out of /etc/X11/xorg.conf.d/), which also didn’t work.

I did install Ubuntu on a separate partition, and found that the issue doesn’t occur there.

There’s still more things I need to try, but I’d like to know if there’s anybody else that has ran into this issue, or if someone can point me to the right direction in debugging this.

Okay so far I’ve tried running “Top Down” under Arch and a fresh Gentoo installation.

The Arch installation had no issues. The fresh Gentoo installation did have the issue.

I figured it out!

It turns out I needed to set CONFIG_INPUT_MOUSEDEV to Y, or M, in my kernel’s configuration.