Get Surface Type from Landscape 4.24

It’s work before 4.24. But now, i can get only DEFAULT type from LANDSCAPE.!

Yes. I think node “get surface type” from node “LineTrace” hit result or “Break structure” - is broken. Any time, if I call this node, i get error. Error access.
4.24… But in 4.22 it worked.

Same here. It worked fine in 4.22.

Having the same issue as you guys and came to this dark side to post about it… Already reported a bug on it as well.

The weird thing is that it works just fine on a rather old project I converted, and not at all on anything new I set up.
As far as I can tell there is absolutely nothing special about the project I converted, except for the fact that the conversion worked even if it was a C++ project with several custom code parts, and other projects with the same C++ simply do not automatically convert.

Glad i’m not the only one. kind of bummed since I can’t publish an update in this condition…

It’s only landscape though. The same material applied to a static mesh, or foliage actor even, works as expected.

Yes. Only landscape type. But in 4.24 release note and “Unreal Engine Issues” - FIXED… Nice joke! thx)))

Having the same problem.