Download

Get rid of motion blur due to camera movement

Hey all, I’m having a couple problems with motion blur.

  1. When the camera rotates, the entire screen is blurred, which actually makes me feel kinda dizzy. Is it possible to disable this, but keep motion blur for basic object movement?

  2. The first person weapons are also blurred when the camera moves. Is it possible to disable motion blur on individual objects?

Thanks in advance :slight_smile:

Find the ‘Global PostProcess’ actor in the Scene Outliner and select it. Then go to the Details tab and find the Motion Blur panel and set the amount to 0.0 and it should now be turned off. If you are using a Post Process Volume(s) then do the same to those.

That disables motion blur completely, I would like to keep it for fast-moving objects if possible :slight_smile:

Also, I believe you could fix #2 in UDK by setting the gun’s base to be the player or camera, but I don’t see anywhere to do that here.

Oh I’m sorry, I misunderstood.

I do not know of a way to do that.

That’s fine, thanks for trying :slight_smile:

I guess it’s not possible yet, there are a lot of basic features like this missing. I’ll just do without any motion blur for now :slight_smile:

I haven’t looked into it myself, but would it be something that you could combine with Depth of Field to achieve the effect you want? Check out the Example Content; And mess around it with, it might help you do what you’re trying to do.

If not, eh. I tried.

We also need to disable moblur on an single object, anyone found how to achieve this?

Hey, I know this advice might be a lit late but I imagine you would achieve this with render layers. I’m not even sure if Unreal 4 supports customizing render layers. I have not looked into that yet but it is how you would do it in other engines.

As an example you may render a motion blur layer that only has your blurring objects, it would do another render pass with non-blurred objects then layer the two. Usually the same principle used for things that glow, the glow effect is usually just another render layer.

Just keep in mind that with each render layer you take a performance hit. Hope this points you in the right direction, even though it is several months late.

On a similar note you can override the default global motion blur settings on each individual camera. This can be adjusted and controlled via blueprints but it is a camera option not object based. Object based things would still be a new render layer.

This can be done with post process volumes. I applied it to bullets.

@cyberdei - How did you apply a volume to bullets? I have a similar problem with bullets. I created a pool buffer with spawned bullets and when I fire I unhide it and teleport it in front of the gun. The problem is that when it is teleported there is a blur. I am looking for a way to stop this blur.

You can try adding a post process component in the projectile class. Or play muzzle flash before teleporting the projectile. The flash/fx should mask it.

I already tried playing around with a post process component and I couldn’t make it work. I tried disabling global blur and only enabling it for bullets and I tried enabling global blur and disabling it for bullets but it didn’t work. I tried also placing post process volumes in the level with different blur settings and shooting bullets through them and it also didn’t work. I am not sure if blur can be changed this way or I am doing something wrong. The blur is so wide that hiding it behind flash is not an option. Besides I was looking for a general solution, because I plan to use pool buffers for many objects.

I think Epic should look into it, bacause actor teleportation should not cause a blur. I don’t know how to request a feature.

Eventually I came out with a simple solution. I change a material to fully masked (invisible) during a teleportation and the blur is gone.